ERR websocket: bad handshake

I have the config file saved to “C:\Windows\System32\config\systemprofile.cloudflared” to run as a service. If I disable the argo tunnel service so it isn’t trying to create the tunnel automatically and move the config file into: “C:\Users%USERNAME%.cloudflared” and run cloudflared tunnel run in CMD I’m able to connect just fine on a client machine. Not sure why I receive a websocket: bad handshake when it runs automatically but not manually, I’ve checked and websockets are enabled, SSL/TLS encryption is set to full and universal SSL is already enabled.

Below is the config file:

tunnel: TUNNELID
credentials-file: C:\Users%USERNAME%.cloudflared\TUNNELID.json
logfile: C:\cloudflared\tunnel.log

ingress:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.