Hi Cloudflare community,

I got my SSL for my WordPress site and chose the flexible encryption mode. I also downloaded really simple SSL plugin on my site, everything seemed to be working fine until my website went inaccessible due to err-too-many-redirects.
I went through the basic troubleshooting process by clearing the cookies and cash with no success. However, I tried to enter my website from a different IP address and it worked normally but I noticed a little delay while loading the pages.
Would you please advise me on this?
I’m quite confused and concerned about this issue.

Thanks in advance,

You currently have a security issue.

1 Like

Although I truly appreciate your reply, it didn’t actually answer my question “why am I getting this error on my IP address while things are working well on different IPs”?
So would you please suggest what is the cause of this issue and how to resolve it?

Thank you,

You didn’t post the domain name, so we can’t check. But it sounds like your site wasn’t working with HTTPS before you added it to Cloudflare, yet you set Cloudflare to use HTTPS. Is this correct?

Yes, that’s correct.
I was unsure about posting my domain name. Can I post it here in this thread so you can check it?

Then @sandro’s advice is spot on. The error you’re facing is because your server is not properly configured for HTTPS. The Origin Certificate approach he mentioned is the right way to handle this.

This embedded link from his post is what I use:


Thank you so much for your time and help.
I’ll give it a go and see what happens.
Have a nice one,

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.