ERR_TOO_MANY_REDIRECTS when proxy enabled

I would greatly appreciate some advise. Whenever my client enables the proxy of traffic through Cloudfare, the site experiences a ERR_TOO_MANY_REDIRECTS; too many redirects between the old .co.uk address and the main .com address. And when we refresh the page, if the address was .co.uk it changes to .com and vice visa.

This is our stack:

  • Cloudways is the webhost
  • The website is a WordPress site
  • There is security plugin called iThemes Security
  • And we have CloudFlare

What we have checked:

  • the .htaccess file is vanilla
  • The WordPress site is set to https:// .com in the General Settings

What we have tried so far:

  • In Cloudflare’s SSL/TLS > Overview settings, changing from Flexible to Full (Strict)
  • In Cloudflare’s SSL/TLS > Edge Certificate settings, ensured Always Use HTTPS was switched off
    (based on this article)
  • In Cloudways Application Settings, switched off the https redirection
  • In iTheme Security plugin settings, switched off the Redirect All HTTP Page Requests to HTTPS settings
  • In Cloudflare’s WordPress plugin, switched off the Automatic HTTPS Rewrites settings
    (based on advise from this Cloudflare article)

We still found the ERR_TOO_MANY_REDIRECTS to be happening after the above steps were taken.

What parts of the stack can I rule out?
What is causing the ERR_TOO_MANY_REDIRECTS error?
What previous steps should I keep doing? (we reversed all the changes).
What new steps we take?

Any assistance greatly appreciated.

Edit:
We have two redirects set up under the Pages menu, could this be a possible source of issues when proxy is switched on?

Your Page Rule to redirect to .co.uk looks correct, though would be more efficient if the match was: *example.com/*

So the problem is your .co.uk is redirecting back to .com

You need to fix the .co.uk site so it doesn’t redirect back to the .com site.

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.