ERR_TOO_MANY_REDIRECTS | This page isn’t working

This page isn’t working

www.pluscszone. com redirected you too many times.

[Try clearing your cookies].

ERR_TOO_MANY_REDIRECTS

Domain name is pluscszone. com

image

What is the SSL mode you’ve set it to?

im set ssl mode is Flexible.

Would you pause cloudlfare for few minutes and resume again & check?

Please try to disable the function Always Use HTTPS at SSL/TLS

Edge Certificates

Are you redirecting https to http and using Chrome?

For some reason no matter what I do when its CF proxied Chrome is always redirecting to https which in my setup redirects to http but Chrome (since 104) ignores this and redirects back. I do not have HSTS enabled.

Having the same issue here, just cropped up recently, Flexible SSL mode but Chrome always tries to redirect to HTTPS on Cloudflare sites.

I have found this is related to the “Support for HTTPS records in DNS” feature in Chrome. If you disable it from chrome://flags/#dns-https-svcb behavior stops.

I can’t seem to find any way to remove the SSL info from the DNS records in Cloudflare to stop this behavior.

I cannot reproduce this behavoir, working fine at my end.
HTTP → HTTPS → www HTTPS 301 redirect

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

Is it fixed now? :thinking:

Either due to the HSTS or “HTTPS-only” feature being enabled.
https://chrome.google.com/webstore/detail/https-everywhere/gcbommkclmclpchllfjekcdonpmejbdp

Unfortunately, this kind of a Web browser / Website behaviour is known to cause issues if your origin host/server doesn’t have an valid SSL certificate installed before moving your domain to Cloudflare. Kindly, read more about it at the article from below:

Before moving to Cloudflare, was your Website working over HTTPS connection?

Kindly, before doing anything at Cloudflare settings, you could determine if you have a valid SSL certificate installed at the origin host/server by your web hosting provider or your own VPS/dedicated server following the steps from below:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS.
  4. Check with your hosting provider / cPanel AutoSSL / ACME.sh / Certbot / Let’s Encrypt or some other and renew it accordingly.
  5. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings at the SSL/TLS tab on Cloudflare dashboard:

2 Likes

No neither are on, I even checked Chrome’s internal cache and no HSTS entry. Also HTTPS-Only is disabled and even if either were on the same problem would occur when CF proxy was turned off.
Since Chrome 104 when CF is proxying it causes the infinite redirect issue, as soon as its disabled with no server changes everything works fine.
I can see no rule that causes this, nor is https only enabled in CF settings. It happens in Full Strict and Full.

Thanks for the suggestions though to eliminate.

@l8tr

Please check if you have installed origin CA certificate to function properly. See the reference made by @fritex on Origin CA

Its pointing to an ELB load balancer running a valid public SSL certificate.

That should not be an issue. I see now the site is loading well. :+1:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.