Answer these questions to help the Community help you with Security questions.

What is the domain name?

Have you searched for an answer?
yes I searched many sites for the answer

Please share your search results url:
When you tested your domain, what were the results?
I ran the curl command to see the redirect on my origin server the result was:
< HTTP/1.1 200 OK
after that i made the same with cloudflare:
< HTTP/1.1 301 Moved Permanently
< Location:

Describe the issue you are having:
checked it on
http redirect to https, and https redirect to http.
Infinite loop.
Everything works fine with flexible ssl, no redirection. But with full it just produce this error.

What error message or number are you receiving?

What steps have you taken to resolve the issue?

  1. Follow community tutorial step by step
    2.Always use https option enabled
  2. Automatic HTTPS Rewrites function enabled

Was the site working with SSL prior to adding it to Cloudflare?
I recently created the site

What are the steps to reproduce the error:

  1. change flexible to full and go to

Have you tried from another browser and/or incognito mode?
Please attach a screenshot of the error:

Welcome to the Cloudflare Community. :logodrop:

Please ensure that your SSL Mode is Full (Strict).

If i change to full strict, there is invalid ssl error. And there is no cpanel at the hosting provider, Can’t import certificates.

You probably need to find a better host then. If you have no valid certificate on your origin server, you will never have a secure site, no matter how you configure Cloudflare.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.