ERR_TOO_MANY_REDIRECTS only on home page

I am getting ERR_TOO_MANY_REDIRECTS on my home page of WordPress site. All other pages other than home page are working fine.

https://www.hashtagepc.com/

What have you done to try and correct this error too many redirects?

@cloonan I checked with domain provider (godaddy). Since I have changed the default nameservers, they don’t have anything to sort it out. They suggested to change back to default nameservers.

But then it will disable https for my site or I have to get SSL from godaddy ( which i don’t prefer due to past experience).

While doing some trouble shooting, I found that if I change my site URL in wordpress settings to include ‘www’ in the URL, the error goes away

i.e. use https://www.hashtagepc.com instead of
https://hashtagepc.com

But then I get error from WooCommerce plugin that this is a duplicate site

Can you try to set SSL to Full (Strict) on this page https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls to fix the TOO MANY REDIRECTS error

A post was split to a new topic: Too many redirects after adding TXT records