My primary domain is showing correctly the Wordpress installation under SSL freshly assigned. However, the moment I am trying to login via /wp-admin I am getting merciless ERR_QUIC_PROTOCOL_ERROR

SSL is set to Flexible by default. When set to strict it generates another error ERR_QUIC_PROTOCOL_ERROR which also pertains the primary domain which is deecunning com

Have literally no idea what causes this and how to fix it.

I am afraid that is insecure and famous for all sorts of issues, such as the one you are experiencing.

Can you pause Cloudflare for a start?


So, I have paused the CF and was able to install a fresh copy of WP to http and tested it working without problem. I have re-enabled CF and tried to reload the https just to get this error again


I am bamboozled :slight_smile:

It needs to work on HTTPS, not HTTP. Did that work?

Do not unpause Cloudflare before it works on HTTPS.

Yes, I am afraid your server is not properly configured for SSL and that’s the issue here.

To fix this, pause Cloudflare and talk to your host to get that fixed, so that the site loads fine on HTTPS. Once it does, it should also work on Cloudflare.

If you need a certificate, you can also take a look at Origin CA certificates · Cloudflare SSL/TLS docs.

I don’t understand what you mean. I have don’t unpause CF I would not be able to run HTTPS as CF is the provider of that, so I will always get an error. When I tried to install WP with CF running I got a message during the installer that no trusted SSL cert. has been detected, but the installation carried on anyway.

No, Cloudflare does not provide SSL, save for mentioned certificate. Your site needs to be secure before you use Cloudflare, hence you need to fix the server.

As mentioned

I am on InfiniteFree hosting, so literally there is no way to communicate this with the host. They don’t provide support for free hosting customers. Only community. I cannot also find any settings in the CPanel to adjust in order to get any effect. I can request free SSL cert that last 90 days. But don’t see a point of that with CF. Been running free hosts before and had no problem enabling SSL.

I just don’t understand why the main domain would load, but anything then I got in redirect loop when going deeper. It just does not makes any sense to me, because it either works completely or not at all in my books. Can’t it be that there is some SSL settings which might interfere?

Then I would recommend to change host. Your site needs to work fine on HTTPS first as mentioned.


  1. Pause Cloudflare
  2. Talk to your host to fix the site and get it to load on HTTPS (or switch host)
  3. Once the site loads fine on HTTPS, you can unpause Cloudflare

Ahh, I maybe I found a solution via self-signed certificate.

A self-signed certificate does not provide security either. You did not read what I wrote earlier, respectively my suggestion for an Origin certificate. That’s a bit difficult then of course.

You need a valid certificate, either any publicly recognised one or an Origin one.

The Origin certificate cannot be used with my current host:

Getting this error in Cpanel:

The certificate uploaded is NOT for the domain name xxxx (Cloudflare Origin Certificate was seen) .

Right, the Origin certificate does not have the domain in the common name but in the SAN, but it’s still a valid certificate. If your host does not accept that, that’s unfortunately an issue on their side.

I’d contact them to clarify that and if that does not work you can always use a Let’s Encrypt certificate or whatever valid certificate they provide.

Interestingly enough I found a guide that would use Self-Signed cert with Cloudfare.

I am afraid that “tutorial” is wrong and provides incorrect advice. As already mentioned, a self-signed certificate can never provide a secure connection

As already written more than once, your current issues are because your site is not properly configured. Make sure it loads on HTTPS without Cloudflare, then it will work straight out of the box with Cloudflare as well.

If you do not have a valid certificate on your server, your site will be generally insecure and you will run into issues, as you already do.

Once your site loads fine, don’t forget to fix your encryption mode as well and set it to Full Strict.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.