ERR_TOO_MANY_REDIRECTS after Granted Login

i got a strange Problem with Cloudflare Tunnels. I configured Tunnels on my systems and those worked great until one day, they just stoped working from itself ( the only thing i changed where switching to the pro plan in Cloudflare ). I barely had time doing anything on my System, so i literaly did nothing.
After i log in ( i use Google Authentication for that but i tried Github Authentication too and made no difference ) i get a ERR_TOO_MANY_REDIRECTS Error in Chrome ( but no difference in Firefox ) and the Service wont load. If i set my IP to Bypass it loads again, so the Tunnel itself works. In my Access - Logs i see the Access is granted, so Authentication works too, but it just somehow doesnt want to load the Service after Authentication.
Searching for this didnt help me, cause everything i find isnt writen in the context of a tunnel and the tunnel itself are working.

Did someone stumble upon the same Error ? At the moment i bypass Traffic for my address ranges to make it work again, but that cant be the longterm solution.

Best Greets


I’m sorry to hear that you are experiencing issues with your Cloudflare tunnels. Based on the error message you are receiving and the fact that the service works when you bypass your IP address, it is possible that there may be an issue with your SSL configuration or certificate.

I recommend checking the SSL settings for your tunnels and ensuring that the certificate is valid and up-to-date. Additionally, you may want to check your Cloudflare firewall rules to see if there are any rules that could be causing the redirect loop.

If you are still experiencing issues after checking your SSL configuration and firewall rules, I recommend reaching out to Cloudflare support for further assistance. They will be able to provide more specialized guidance and support to help you resolve this issue.

Tools that I would use:

  • Cloudflare documentation and support resources.
  • SSL certificate management tools.
  • Firewall rule configuration and management tools.

I hope this helps, and please let me know if you have any further questions or concerns.

I have the same problem. I set up several tunnels to HTTP:// services over a year ago. They worked perfectly using Chrome. Suddenly, a few month’s ago they stopped with the ERR_TOO_MANY_REDIRECTS. This happens on all sites with HTTP: protocol, even those without authentication.

I tried everything I can think of, but nothing works.

I look in the browser dev console and its getting a 301 for followed by a 301, then back to https:/........