Err Too Many Redirects A AAAA records for both Root and Subdomain

I am new to Cloudflare. I set up the nameservers, after a while and after disabling http to https redirects from my server to avoid the common loop, everything was working fine. Then i proceeded to add my subdomain to the dns records, and that was when everything went on fire. Neither my root domain nor my subdomain work, both display err too many redirects error. I don’t understand. I have tried messing with https redirects, ssl certificate settings (flexible, stricts, etc), but nothing works. What was especially weird, was that even when everything was fine with root domain on frontend, i couldn’t access wordpress panel on my site through wp-admin. My hosting provider insists it’s a problem with Cloudflare settings. Please help I am losing my mind over what could be the problem.

This one should help you to get this solved:

1 Like

Adding page rule somehow fixed frontend. Still can’t access /wp-admin though

Maybe it wanted some time because I purged cache. Working fine now. Still don’t understand why it needed the rule since i already have http redirect to https from Cloudflare settings. Oh well. It is fixed now, thank you

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.