ERR SSL VERSION OR CIPHER MISMATCH without config change

We have not changed any configuration in Coludflare nor on our servers, however suddenly I started getting error on all the browser as below.

ERR_SSL_VERSION_OR_CIPHER_MISMATCH

Unsupported protocol

The client and server don’t support a common SSL protocol version or cipher suite.

This was working till yesterday evening, now stopped working.

  1. We have origin certificate on Server
  2. SSL is in Full strict mode
  3. Universal Certificate is also active

Also followed this topic ERR_SSL_VERSION_OR_CIPHER_MISMATCH but did not help.

What should I do?

Without knowing the domain, there’s nothing we can suggest beyond what you’ve already tried.

@sdayman thanks for your quick reply and valuable time, I just found out that our domain is expired. Apologies for inconvenience.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.