Err ssl protocol error

Initially it was working fine. I used Flexible certificate. But after I experimented with Lets Encrypt Certificates within my website hosting provider Infinityfree, and disabled this certificate, and reverted back to Cloudflare Flexible certificate, but for some reason Cloudflare was still “redirecting” my https request and showing Let’s Encrypt Certificate, despite they were removed from my hosting provider. I deleted my domain account with Cloudflare and setup Flexible certificate again, its active but now, and it does not use Let’s Encrypt Certificate but instead, cannot use any. For my https requests I am getting the following error indicating there is no SSL connection

This site can’t provide a secure connection
sent an invalid response.
ERR_SSL_PROTOCOL_ERROR

I believe like Cloudflare caches in somehow the previous settings, I tried to clear also my browser, also use different browsers, clear caches at the Cloudflare, but I cannot get Flexible Certificate sorted. I tried to disable the universal certificate, and then reissue the certificate, it does not help too. When connecting over http protocol I can connect to my website, since Flexible certificate uses http to connect to the hosting provider, it does not work without any issue regardless whether there was Lets Encrypt certificate before installed on the website hosting server.

There is no such thing, you still need a certificate on your server. Install that first.

Again, there is no such thing. What you are having right now is only the proxy certificate and that means your site is still insecure.

Again, first install a certificate on your server.

Now you have a certificate, however it is invalid.

If you dont require SSL, simply turn it off altogether on Cloudflare.

SSL is not required for that.

Google recommends SSL, precisely for security reasons and for that you need a certificate on your server. We are going in circles.

Well, what do you want me to say?

I told you what to do in the first response. Install a certificate and the issue will be fixed in no time.

That is technically not possible. Your nameservers are at dns-parking.com at this point. If you still get something Cloudflare related, that would be because of DNS propagation and that is outside of Cloudflare’s control.

yes the name severs already point to another hosting provider, sorry the word impossible is not valid, all DNS entries are globally updated long time ago, but clearly CloudFlare still in somehow overwrites those DNS entries

It is. As I already said, your domain does not use Cloudflare anymore. If it still resolves to Cloudflare for you, then you have an issue with your resolver, not Cloudflare. But I already said that and I am not sure why I have to repeat myself.

Again, your domain is pointing to 81.16.28.90 at this point and Cloudflare is not involved whatsoever.

Evident here as well -> sitemeer.com/#emvca.com

I am not sure what is so hard to understand.

Cloudflare is not involved any longer

You need to get your resolver to refresh whatever outdated value it keeps. This is not a Cloudflare issue. Do you understand that?

Then you have not cleared the cache.

For the Nth time. Cloudflare has nothing to do with your domain at this point. Either there is an issue with your current nameservers or with your own DNS resolver.

Your domain is not using Cloudflare, hence Cloudflare has no influence whatsoever here. Please familiarise yourself with DNS and how it works, otherwise we will be going in circles for even longer.

You dont seem to be familiar, otherwise you wouldnt make these claims.

Anyhow, we have reached the end of the discussion at this point. Your domain is not using Cloudflare, hence the community is not the right place for discussing DNS issues of your domain. Please refer to StackExchange and alike if you have any other questions on how to configure your domain.