ERR_SSL_PROTOCOL_ERROR issue across whole network

We were setting up SSL for the website rskolkata.com. We first set up Cloudflare for the site. Everything was okay in Cloudflare site including DNS server settings. However, something happened which corrupted SSL certificates across the whole network. We tried to access the website in ubuntu 20.10 and windows 10 in all the machines in the network in all the browsers (Chrome, Mozilla, Opera) in both normal mode and incognito mode. We always get the error ERR_SSL_PROTOCOL_ERROR in Chrome and in Mozilla, the error is SSL_ERROR_INTERNAL_ERROR_ALERT. We tried the following command in Ubuntu:

sudo apt-get install --reinstall ca-certificates

This worked on a machine (say machine A) outside the affected network (but the same machine which was initially in the corrupted network). When we tried the same command on the Ubuntu machines on the affected network it did not work. We also tried to clear the SSL state in Chrome on Windows machine which did not work. Then we tried the following:

sudo apt-get -f install
# stop if you saw any errors

sudo dpkg --purge --force-depends ca-certificates
sudo apt-get -f install

We tried the above, which also failed to solve the issue.

The website opens without any issue outside the affected network.

We checked the website up status in the website https://www.websiteplanet.com/webtools/ which shows the site is running. The SSL is working properly.

The ‘machine A’ when brought to the affected network again, starts to give the error again.

However, as we are the developer for the site we need to access the site from our office network. Please suggest a solution.

This looks to be strictly an internal error, so I don’t know what this has to do with Cloudflare.

This topic was automatically closed after 30 days. New replies are no longer allowed.