ERR_NAME_NOT_RESOLVED After Switching to Cloudflare


#1

Hello,

Yesterday I set up one of my sites in my reseller account with a free cloudflare account, but now the site will not load on the local ISP server (shaw cable). The site seems to load fine as soon as I turn my wifi off, but as soon as wifi goes back on, I get the error page. My hosting provider hasn’t been able to locate the issue, other than suggesting there’s a cached bad DNS record.

I ran a test through here, http://www.dnsinspect.com/thailemongrass.ca/10169422, and there are errors but I’m not knowledgable enough on this stuff to fully understand how to correct these issues.

The DNS records I had to manually input into cloudflare for the site are all good, I’ve checked multiple times.

When running the site through whoshostingthis, http://www.whoishostingthis.com/?q=thailemongrass.ca, it’s telling me it’s going through cloudflare, but still the site doesn’t load for me while using the Shaw ISP. Claire also doesn’t indicate that the site is using cloudflare when trying to load it.

Website is thailemongrass dot ca

I’m not sure what other information would be good to share, please let me know if I’m missing anything. I’m totally at a loss for understanding what’s happening. Any help would be so appreciated.

Thanks,

Matt


#2

Update:

I added the godaddy nameservers to the cloudflare account, because I saw they were listed in the dns zone records in the fullhost (hosting provider) whm account. I’m not sure if that’s what’s made a difference, but the site is now loading for me when using the Shaw servers. http://www.whoishostingthis.com/?q=thailemongrass.ca is still showing cloudflare as the host.

If anyone has any insights into why these issues were happening, I’d love to be educated on this.

Thanks,

Matt


#3

Update:

It seems the issue was that when I set up the account for this domain, I chose the option “Use the nameservers specified at the Domain’s Registrar. (Ignore locally specified nameservers.)”. This and ISP caching were both causing the problem.


#4

Your domain doesn’t fully point to Cloudflare (see here).
If your hosting is Godaddy here you can find the tutorial.