ERR_CONNECTION_TIMED_OUT / Error 522

Hi all! Hope you are doing fine. My name is August,

Currently I have my domain (kijk.net) with Namecheap everything was working well using their nameservers and the config I had there.I chose to move my registrar from Namecheap to Cloudflare today however it will not take place until 5 days from now. I did have my nameservers changed to Cloudflare already:
anirban.ns.cloudflare.com
rosalyn.ns.cloudflare.com

Now when logging in to my account at Cloudflare I see that the nameserver setting were taken over already:
A - kijk.net - 189.132.4.37 - TTL Auto - Proxied
MX - kijk.net - kijk.net - TTL Auto – DNS only
TXT - _amazonses - xxxx(left out for security reasons) - TTL Auto - DNS only

And all should be working fine as this was the exact same config I had using Namecheap
Also I can confirm the server that is behind this IP has more than sufficient capacity:

  • 16 core CPU / 32 RAM / No services running except of a NAS at a specific port and a 100Mbps dedicated line.

However I still receive the following ERR_CONNECTION_TIMED_OUT / Error 522 whatever service/ports I access through the domain “kijk.net”

Also I can confirm that the ports are correctly opened as I have not changed a thing on the server or the server´s network´s end, and everything was working just perfect before I changed the nameservers to Cloudflare.

I hope someone can guide me here as I have basic knowledge but am not an expert either.

Thanks so much for your time!

Are you sure you don’t have some server firewall set up? I can’t connect to your server using your A Record’s IP address:
curl -I http://kijk.net --connect-to ::189.[redacted]
curl: (7) Failed to connect to 189.[redacted] port 80: Operation timed out

Ah, Cloudlfare doesn’t Proxy those. It’s meant to be a website proxy service unless you’re using Spectrum on an Enterprise plan.

1 Like

Really? I didn´t know that, thanks for the tip!!
However, I just did a test, setting my server to use port 80 and 443 to run the services I need and opened these ports on my firewall too however still the same issue here

Are those services using HTTP/S?

1 Like

Something looks like it’s working.

1 Like

Correct HTTPS is enabled on the server

Yep! it started working now!! Man, you saved me another night of sleep! Thank you so much for your quick and successful assistance!!!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.