Err_connection_closed


#1

Hi

I need help on this website

Each time i try to move this website to Cloudflare there is problems.
Now i get ERR_CONNECTION_CLOSED

I don’t know why.
Please could you help me urgently ? otherwise i will go back to my hoster server name…


#2

Your site generally loads fine

http://sitemeer.com/#azur-m.fr

Can you post the output of the follow four command line commands, from your local machine?

nslookup azur-m.fr
ping azur-m.fr
nslookup www.azur-m.fr
ping www.azur-m.fr

You are probably using some stale DNS entry and still connect to a previous IP address.


#3

nslookup azur-m.fr

Server: 192.168.0.254
Address: 192.168.0.254#53
Non-authoritative answer:
Name: azur-m.fr
Address: 104.31.94.133
Name: azur-m.fr
Address: 104.31.95.133

ping azur-m.fr

PING azur-m.fr (104.31.95.133): 56 data bytes
64 bytes from 104.31.95.133: icmp_seq=0 ttl=54 time=38.579 ms
64 bytes from 104.31.95.133: icmp_seq=1 ttl=54 time=37.473 ms
64 bytes from 104.31.95.133: icmp_seq=2 ttl=54 time=38.617 ms
64 bytes from 104.31.95.133: icmp_seq=3 ttl=54 time=36.972 ms
64 bytes from 104.31.95.133: icmp_seq=4 ttl=54 time=38.528 ms
64 bytes from 104.31.95.133: icmp_seq=5 ttl=54 time=38.248 ms
64 bytes from 104.31.95.133: icmp_seq=6 ttl=54 time=38.373 ms
64 bytes from 104.31.95.133: icmp_seq=7 ttl=54 time=37.466 ms
64 bytes from 104.31.95.133: icmp_seq=8 ttl=54 time=40.122 ms
64 bytes from 104.31.95.133: icmp_seq=9 ttl=54 time=45.445 ms
64 bytes from 104.31.95.133: icmp_seq=10 ttl=54 time=44.528 ms
64 bytes from 104.31.95.133: icmp_seq=11 ttl=54 time=36.724 ms

nslookup www.azur-m.fr

Server: 192.168.0.254
Address: 192.168.0.254#53
Non-authoritative answer:
Name: www.azur-m.fr
Address: 104.31.94.133
Name: www.azur-m.fr
Address: 104.31.95.133

ping www.azur-m.fr

PING www.azur-m.fr (104.31.95.133): 56 data bytes
64 bytes from 104.31.95.133: icmp_seq=0 ttl=54 time=40.843 ms
64 bytes from 104.31.95.133: icmp_seq=1 ttl=54 time=40.029 ms
64 bytes from 104.31.95.133: icmp_seq=2 ttl=54 time=41.758 ms
64 bytes from 104.31.95.133: icmp_seq=3 ttl=54 time=38.700 ms
64 bytes from 104.31.95.133: icmp_seq=4 ttl=54 time=36.846 ms
64 bytes from 104.31.95.133: icmp_seq=5 ttl=54 time=39.495 ms
64 bytes from 104.31.95.133: icmp_seq=6 ttl=54 time=40.519 ms
64 bytes from 104.31.95.133: icmp_seq=7 ttl=54 time=37.964 ms
64 bytes from 104.31.95.133: icmp_seq=8 ttl=54 time=38.077 ms
64 bytes from 104.31.95.133: icmp_seq=9 ttl=54 time=38.384 ms
64 bytes from 104.31.95.133: icmp_seq=10 ttl=54 time=39.304 ms
64 bytes from 104.31.95.133: icmp_seq=11 ttl=54 time=37.207 ms
64 bytes from 104.31.95.133: icmp_seq=12 ttl=54 time=38.533 ms
64 bytes from 104.31.95.133: icmp_seq=13 ttl=54 time=37.842 ms


#4

Well, that does resolve to the right IP address. Do you have any proxy configured in your browser?
Can you post a screenshot of the error?


#5

Not that I know.

Here is a screenshot


#6

That’s an SSL issue:


#7

Hang on, I could swear I checked HTTPS earlier as well but now I also get an error.

Yes, as @sdayman suggested, it is a certificate issue.


#8

OK thank you.

So i was using the hoster based SSL certificate and i had setted Crypto/SSL on Off and i disabled Universal SSL.
Now I disabled the hoster based SSL certificate and i enable Universal SSL and set Crypto/SSL on Full.

The website comes back but without any httpS.

Do you think i am in the right way ?


#9

In that case it wasnt an error, you simply disabled HTTPS in which can it obviously cant work.

What do you mean by disabled? You should still have the certificate on your server.

Possibly. Definitely do not disable HTTPS, neither on your host nor on Cloudflare.


#10

I went on my hoster manager panel to set SSL on none.
Because yesterday and before i was already trying to move this site to Cloudflare with this setting :
SSL : On on my hoster manager panel
SSL : Full on Cloudflare manager
Universal SSL : Enabled

And it was not working too…there was an too many redirect error.

Could you confirm me which is the settings for SSL on each manager please ?


#11

I am not familiar with your host’s control panel. You should basically have a valid certificate on your server, one way or the other.

As far as Cloudflare is concerned, “Full strict” is the “best” choice, but it does require that valid certificate mentioned earlier. If your certificate is either self-signed or expired you can also choose just “Full”, dont pick anything below that. Also make sure to enable “Always-use-HTTPS” to get an automatic redirect to HTTPS.


#12

Here is a screenshot of my host manager.

If i try to resume what i understood:

  • i may have to enabled the SSL on my hoster panel
  • set Cloudflare on “Full Strict”
  • always make enabled “Always-use-HTTPS” and " Universal SSL"

Am i right ?


#13

Sounds about all right.

You’d definitely have to have SSL enabled on your server, otherwise Cloudflare cant connect.


#14

Ok i will try all your advice and will come back to tell you if i succed
Thank you


#15

So… i enabled SSL on my hoster manager,
and on cloudflare
i setted SSL full strict
Always use Https enable
Automatic Https rewrite enable
and enable universal SSL

And it works fine now: :slight_smile: Thank You


closed #16

This topic was automatically closed after 31 days. New replies are no longer allowed.