Err_cert_validity_too_long

Answer these questions to help the Community help you with Security questions.

What is the domain name? jctterra.ca

*Have you searched for an answer?*yes

*Please share your search results url:*Cloudflare "ERR_CERT_VALIDITY_TOO_LONG" - Google Search

When you tested your domain using the Cloudflare Diagnostic Center, what were the results? diagnostic center page does not seem to work. Takes me to a different resource page.

Describe the issue you are having: SSL Not working. When going to JcTTerra.ca receiving message listed in title.

*What error message or number are you receiving?*See Title

What steps have you taken to resolve the issue?

  1. Searched on Cloudflare and Google. Only 1 reference to this error states that rules have changed and SSL Certificates can no longer be longer than 13 months. If that is true then why does Cloudflare offer 15 years?

*Was the site working with SSL prior to adding it to Cloudflare?*Not applicable. Site was already with Cloudflare. Replaced server and tried to update certificates for new server.

What are the steps to reproduce the error:

  1. Go to JcTTera.ca

*Have you tried from another browser and/or incognito mode?*Yes Only receive this specific error from outside my network. Error from inside network is the standard “NET::ERR_CERT_AUTHORITY_INVALID

Please attach a screenshot of the error:

The 15 years are the Origin Tunnels which are only good between your origin and Cloudflare. Cloudflare doesn’t offer certs to install on your host outside of origin certificates. You likely need to change your DNS record from :orange: to :grey:.

1 Like

My DNS Record has been proxied for several years now without any issues. Only since I replaced the server am I having issues. Something did not transfer over properly with regards to SSL but I am not sure how to figure out what it is. The new server is just a variation on the old one. Synology DS1821+ instead of DS1512+. In fact the SSL seemed to be working except that when checking on the DNS it was not giving my proper IP address but instead Cloudflare’s IP addresses. That is why I decided to redo the SSL Certificates. But now it is worse because the SSL is now not working at all. Previously it showed as working for my main apps that I access but not my additional wordpress domains and some additional apps. Now it Ping’s properly with my IP address but the SSL is not working at all.

Also the “Too_Long” error only presents itself outside of my Network. Inside I get the standard SSL Not Valid error as previously mentioned. Not sure though what the means in terms of fixing it.

Ok so it seems to be back to working now. I disabled / reenabled Cloudflare and tried “Development” mode. But now I am back to returning Cloudflare’s IP address when pinging my domain. Truth be told I am not sure if that was the case before switching over the servers or not. But there are some aspects of my system that are not working anymore and I don’t know if that is related or not? Mostly to do with additional wordpress domain and sub domains.

Carl.

This seems like something had the incorrect IP cache, and it got flushed out.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.