ERR_CERT_COMMON_NAME_INVALID SSL Status showing as ‘deleted’

Describe the issue you are having:
The Universal SSL status is deleted. I’ve tried Disable Universal SSL button, then wait 15 minutes and then click it again to Enable it, but it doesn’t work. I can’t open a Support Ticket since Customers on Free plans can only submit tickets for billing, account, and registrar issues.

When you tested your domain, what were the results?
Your connection is not private

Have you searched for an answer?
Yes but I didn’t find one

Please share your search results url:


What steps have you taken to resolve the issue?

  1. I’ve tried the Disable Universal SSL button, then wait 15 minutes and then click it again to Enable it → Didn’t work
 curl -X PATCH "`{zone_id}/ssl/universal/settings`" ^
     -H "X-Auth-Email: {account_email}" ^
     -H "X-Auth-Key: {global_api_key}" ^
     -H "Content-Type: application/json" ^
     --data "{\"certificate_authority\":\"digicert\"}"

Return {“result”:{“enabled”:true,“certificate_authority”:“digicert”},“success”:true,“errors”:,“messages”:} → Still didn’t work

Was the site working with SSL prior to adding it to Cloudflare?
It worked before but after there is an email about the website being deleted from Cloudflare, it never work again.

Have you tried from another browser and/or incognito mode?

Is you website currently active on Cloudflare? That is, if you go to, does it say active under your domain?


Thank you for your reply. Indeed it was deleted before, then I resubmit and add the website to Cloudflare again and now the website is Active.

I believe that once the website is deleted the SSL is also deleted. I need to recover the SSL but I don’t know how. The status of the SSL remains deleted even after my website status is active.

It looks like the SSL certificate for your .com domain was deployed two days ago and is showing active. I’m not seeing the cert error on your website. Were you able to resolve the issue?

Dear emanova,

Thank you for reaching me. I have tried add another of my website ( This website are working fine. However, the SSL for the other website is still deleted. Can you please re-activate the SSL of this website for me please?


I am not seeing any issue on the other domain in your account. It looks like the SSL certificate for this one has been active for a while and is set to renew soon.

Are you seeing the error on a subdomain?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.