Entering Cloudflare Nameservers crashes site

I’ve read other posts about this, but nothing that helps my situation. I have a client’s site that is a revenue-generating site and cannot go down. However, after comparing all of the DNS records in CLoudFlare to the records at the web host and verifying they’re the same, I changed the Name Servers at the Registrar to point to CloudFlare. The site immediately went down and I needed to revert the Name Servers back to their original.

I then decided to take a testing website and create a CloudFlare account and went through the same process and everything went as it should. The test site did not go down. The only difference I can identify between the two sites, is the client site is on a VPN and in CloudFlare I do not see the IP address of the VPN server listed anywhere. Other than this, all other DNS records are a dead match.

Any thoughts?

Can you please be more specific? What error did you see?

Another option for troubleshooting is to Pause Cloudflare on Site. It’s in the lower right corner of the Overview page for your domain at dash.cloudflare.com. It will put the domain in DNS Only mode, which should be identical to how it is with your original name servers.

Thank you for your prompt response. It was as if the site was gone- “Page not found” error.

I’m not really sure how putting CloudFlare in pause mode helps me troubleshoot(?). If I were to put it in pause first, and then change the name servers, I assume it will keep the site up. If I then un-pause it and it goes down, how quickly should it come back up if I pause it again?

Last night when it went down and I reverted the name servers back, it took close to an hour to come back online. I’ll be in trouble if I take the site down for an hour again! Do you think the issue could be related to the website residing on a VPN? It’s a different IP address than what shows in all of the DNS records.

The other half of my Pause Cloudflare routine is making sure the site is working with HTTPS before you put Cloudflare on the site. That’s the #1 cause of broken sites when they go on Cloudflare.

Name server changes take too long. That’s why I recommend the Pause option. That propagates in less than five minutes.

1 Like

Any thoughts on the VPN posing an issue?

I’ve never heard of hosting a website through a VPN. Maybe I haven’t been paying attention and don’t know why someone would do that, as it’s pretty inefficient. But generally if a site works properly with HTTPS without Cloudflare, using Cloudflare to proxy it should be somewhat transparent.

2 Likes

My error. Not a VPN it’s a VPS (Virtual Private Server)

So, unfortunately, I have no resolve to my issue. All of the DNS records in CloudFlare are a dead match to my website host’s settings, yet changing Name servers takes the site down. As for putting CloudFlare on hold, I have no understanding of how that enables any kind of “troubleshooting”. The site is secure with SSL, so I’m not sure how pausing the CloudFlare routine verifies HTTPS?

I only have a basic level of understanding of all of this, so any assistance (in layman’s terms) is appreciated.

Without an actual error or domain name to troubleshoot not much the community can offer afaik.

3 Likes

Hi. Thanks for responding. I believe in my post I put the error. It was “page not found”. As for the domain name, you’re the first to ask. It’s athletechnews.com.

More like error 404 not found or?

I see it fine, at least from my end for now. It’s a WordPress site as from my point of view working over HTTPS as far for now.

But, I see nameservers are bluehost:

;QUESTION
athletechnews.com. IN NS
;ANSWER
athletechnews.com. 21600 IN NS ns1.bluehost.com.
athletechnews.com. 21600 IN NS ns2.bluehost.com.

May I ask why didn’t you waited for a few hours? DNS propagation time usually takes up to 24-48 hours to complete.
Also, have you flushed the DNS records in between? (there are tools like 1.1.1.1 — the Internet’s Fastest, Privacy-First DNS Resolver and Flush Cache  |  Public DNS  |  Google Developers)
Furthermore, may I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?
Maybe your origin host / server did not allowed Cloudflare to connect to it? Any Firewall running or have you checked, if you have access, the log files just in case if they containt some usefull information?

1 Like

Yes, the site is fine, because I’m not using Cloudflare name servers. If I do, it crashes immediately.

I am happy to hear that it’s a secured one and working well!

Ouch, I am sorry to hear this.

Nevertheless, could you please try to answer on my questions from above post?

1 Like

I will try again in the very early morning (Eastern Standard Time) and record exactly what the error message is.

As for why I didn’t wait a few hours for it to propagate, I simply cannot. This is a revenue generating website and advertisers don’t want to accept the site being offline for hours.

Any time I have moved a website from one host to another and changed the name servers, the site doesn’t go down. It takes time for the propogagatiion, but just switches over without being down for more than a moment.

That’s the main issue.

I have had 4 domains - or rather webshops WordPress/WooCommerce - transfering in the past month from SiteGround and I used the approach where I set up all correctly, but I left all the DNS records :grey: (DNS-only).
So it continued to work “as-is”, served from the right hosting (rather than from a new one and being proxied :orange: as it is currently now on).

I would suggest doing the same, and just before you change the nameservers, make sure all the records are :grey: and not :orange:.
Later on, when the nameservers propagate, we could continue troubleshooting what happens when you turn on the proxy mode :orange: when all the people go asleep :slight_smile:

Nevertheless, the DNSSEC is not being in use, so one worry less :wink:

Also, I would suggest to lower the TTL value for your records at current hosting/DNS management zone like cPanel, etc. to 300 (just in case if they are set up to 14400 by default on some).

2 Likes

Fritex,
Thank you for all of this information. For reasons I cannot explain, I have had very different results this morning (8am, New York).

The first thing I did was put CloudFlare into “Pause” mode, as suggested by sdayman in this post above. This, I believe, reverts Cloudflare to DNS and not Proxied.

I then went to Registrar (GoDaddy) and changed Name servers to CloudFlare, expecting the site to crash immediately, but it did not. I monitored propagation with DIG tool and about 30 minutes later, I could see that the name servers had updated from Bluehost to CloudFlare.

Finally, I removed Pause mode in CloudFlare and everything seemed to be working on my computer and Mobile.

Approximately 30 minutes after removing Pause mode, I checked on my Mobile and the site wouldn’t load. I had “This page isn’t working, redirected too many times” error. (See screen capture below)

I kept checking my mobile and after another 15 minutes, the site loaded again. However, when checking on my Wife’s iPhone and my daughter’s iPhone, in Safari browser, the site would not load (I have a Droid, running Chrome and it was fine). I then checked both iPhones using Chrome and the site loaded fine, but will not load with Safari. (See screen capture below)

I now put the CloudFlare back into Pause mode and it is working in Safari. I am not sure what is different about Safari that it would not work, but that is the current status. Interestingly, both error messages in screen captures refer to “redirects”.

I appreciate the assistance you and sdayman have provided me, so thank you both.


Screen Capture on Droid:


Screen Capture on iPhones:


httpsathl

It’s the DNS propagation, could be different for local ISP.

Okay, now I see the nameservers are Cloudflare, but not everywhere yet.

;QUESTION
athletechnews.com. IN NS
;ANSWER
athletechnews.com. 21600 IN NS frida.ns.cloudflare.com.
athletechnews.com. 21600 IN NS hal.ns.cloudflare.com.

So I would suggest keeping either “Pause” or make sure the records are :grey: (DNS-only) even without “Pause” for the next 12-24 hours.

Some visitors may end-up using records from their local ISP DNS cache, while the other will go through Cloudflare’s.
Nevertheless, in both case scenarios, the visitors will end up at the current hosting as the DNS records are pointed to and set to :grey:

When you turned on the proxy mode, or rather :orange:, the error in terms of “Redirection” could be due to few possible reasons:

  1. Non-www to www
  2. HTTP <-> HTTPS
  3. There was my question from above if you could check, which SSL/TLS option was selected under the SSL/TLS tab in the Cloudflare dasboard for your domain name?

In terms of redirection loops when the :orange: (proxy) mode is enabled and regarding above 3 points I stated, it would be good to consider the information from below aritcles:

I see it loads fine, but it’s going through Cloudflare Nameservers - at least from my end and from my ISP both fibre (fixed home line) and mobile data (cellular).

But yes, you are currently using Pause mode to make it work - that’s correct for now.

1 Like

Good day Fritex. I have read through all of this information thoroughly and I understand, thank you. To answer your question, the SSL/TLS is set to “flexible”.

In reading through the tutorials, it appears I should make sure that http:// redirects to https:// and the SSL/TLS is set to “Strict”. If I enter http:// in my browser, it does indeed bring me to https:// for this website, so I assume redirect is set in place. I am not sure where to check that on my host server, but I can contact support at Bluehost and they will verify.

It also appears I can create a page rule in CloudFlare to always use https://. Perhaps I should add this page?

There is an issue with redirection loops.

Should be as already stated Full (Strict) - as we already acknowledged your Website/domain has a valid SSL certificate and was working over HTTPS before moving to Cloudflare, even running it on Pause mode worked fine.

Nevertheless, there is an option “Automatic HTTPS Redirection” and “Always Use HTTPS” in Cloudflare in case if needed.

Yes, you can create a Page Rule. But from my point of view, could be I am wrong, you do not need to create a Page Rule, rather you could apply this on the whole domain and sub-domains (only the :orange: is needed for each of the DNS hostnames).

To find them, please navigate to the SSL/TLS tab → select Edge Certificates → Scroll down a bit to find Always Use HTTPS and/or Automatic HTTPS Rewrites options.

If the records are :orange:, maybe Cloudflare is doing the thing here.
Otherwise, in terms of your hosting provider and where should you check for this, I would suggest looking into the .htaccess file or .vhost file (if available to you at your root, public_html, web directory via FTP, or a File Manager interface).

Full (Strict) should solve the problem of redirections.

Nevertheless, you can check if your WordPress is configured to work over HTTPS using the below articles. Please, make sure your WordPress website (domain) is working over HTTPS, the WordPress admin too:

I have enacted your suggestiod changes and removed from Pause mode. So far, everything seems to be working ok. I will monitor for the next few hours to be certain.

1 Like