Ensuring the New SSL certificate is used

Answer these questions to help the Community help you with Security questions.

What is the domain name?
titanlite com au

Have you searched for an answer?

Please share your search results url:
Looked at several issues with SSL certificate items, but none are specific enough to our situation that I am confidence on what to change. Live site/customers.

When you tested your domain using the [Cloudflare Diagnostic Center], what were the results?
That URL redirtected to /hc/en-us, no results for my domain.

Describe the issue you are having:
Cloudflare does not appear to be picking up the new RAPID SSL purchased from Crucial for our server.

What error message or number are you receiving?
No Error, padlock shows “Let’s Encrypt”

What steps have you taken to resolve the issue?

  1. Checked with Crucial and they have confirmed the certificate has been applied and they provided screenshots.
  2. Waited overnight to ensure plenty of time for the update to be processed.
  3. Tried to confirm if we need to turn on Full (strict)
    Encrypts end-to-end, but requires a trusted CA or Cloudflare Origin CA certificate on the server

Was the site working with SSL prior to adding it to Cloudflare?
SSL is still working but with the free version only

What are the steps to reproduce the error:
Check the padlock

Have you tried from another browser and/or incognito mode?
Yes, Edge, Firefox and Chrome all show “Lets Encrypt”.

Please attach a screenshot of the error:

You do, if you have any other mode you disable encryption.

As for the issue you mentioned, the certificate you get displayed in the browser is the proxy certificate, not the server certificate. The latter is not visible in the browser.

As long as your encryption mode on Cloudflare is Full Strict and your site loads fine, everything is correctly configured.

1 Like

Thanks for the response.

I have changed to Full(Strict) this morning and tested 3 times however certificate for the site still says “Let’s Encrypt”.
Latest test was 2.5 hours after the website changed to Full (Strict).

Update 04/May/2023 12:52pm, turned off Cloudflare for the site and the certificate is not showing.

So confirmed that the certificate is not passing through to the browser when Cloudflare is not paused.

Ehm, did you read what I wrote?

It obviously is a Let’s Encrypt certificate as that is what Cloudflare used for the proxy certificate. There is nothing “passed through”.

And if you did not have it on Full Strict until now, your site was insecure until now. Keep that on Full Strict.

Describe the issue you are having:
Cloudflare does not appear to be picking up the new RAPID SSL purchased from Crucial for our server.

I’m trying to get a screenshot, but RAPID SSL in the browser only shows when I turn off Cloudflare. I want to use the secure SSL from Rapid with Cloudflare, so turn on Cloudflare and have Cloudflare pickup the Rapid SSL certificate that is currently running on the Crucial Server.

To be clear, if I turn on Cloudflare (unpause), it goes back to the Lets Encrypt certificate.

I don’t know how to load the certificate onto Cloudflare if it does not pick it up from the Hosting server.

Sorry if i’m not being clear.

You are being clear, but as already mentioned, nothing is “passed through”. You simply get the proxy certificate. If you need to have your own certificate shown in the browser, you can only unproxy or upgrade to a Business plan where you can provide your own certificate for the proxy.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.