Endless redirect with wordpress


#1

I keep getting a redirect endless loop error when Cloudflare is enabled

2 weeks ago I enabled flexible SSL which appears to have caused the problem. However I deleted the account after a couple of days to start again. Waited another week so that the cache should have been cleared out but am still getting the error

Flexible SSL is still off

Does anyone have any clues as how I would resolve this?

Thanks Peter


#2

What technology you are using for your website?
CMS, Webserver…
Flexible SSL can cause such an infinite loop and here are some workarounds.


#3

Wordpress and cPanel.

I am not using Flexile SSL any more as it seemed to cause the original problem


#4

So you’re saying your site is in an infinite redirect loop right now?

What’s the URL? I usually see infinite redirects when Cloudlfare is set for HTTPS, but your site is set (in General->Settings) for HTTP.


#5

No the site is not currently in a redirect loop as I have paused Cloudflare

If I “resume" the site on cloudflare it will give an redirect error immediately

I think cloudflare is still presenting the site as HTTPS even though its off

Regards Peter


#6

When I troubleshoot a broken Redirect, I hit the command line and:
curl -v https://example.com (adjust the URL as needed)

And watch the response to see where it’s sending me. Then repeat with whatever URL the response told you.


#7

Hi …
Have you tried these steps?
1 - install this plugin: https://wordpress.org/plugins/cloudflare-flexible-ssl/
2 - - enable flexible ssl on CloudFlare
3 - on your wordpress :
go to settings> general
WordPress Address (URL): set to > http
Site Address (URL): set to > https

On the page rules:


#8

None of this worked for me, but I found a way that worked instantly and fixed cloudflare SSL issues. Check out the guide here: https://www.maherhackers.com/fix-cloudflare-redirect-loop-and-other-ssl-issues/

Hope it helps.