Endless loop redirect

Recently created my website it worked before, but now when i go to the website i get ERR_TOO_MANY_REDIRECTS. I use google sites and my domain is www.dockware.cc It also doesnt work without www lol. I’ve deleted all rules and cleared all my browser cookies and history.

Welcome to the Cloudflare Community. :logodrop:

Do you have a DNS entry for dockware.cc? That name does not currently resolve. The most obvious explanation would be that DNS record was created. Adding the appropriate A or AAAA record should fix that.

One of the most common reasons for ERR_TOO_MANY_REDIRECTS is using the SSL setting of Flexible which connects to your origin insecurely using HTTP. This can cause a loop if your origin tries to redirect to HTTPS. The best solution is to use Full (Strict) SSL.

The following Community #tutorial topics have more details if you are interested.

Thanks for your reply but i dont know how to get my A record as you said

Your apex name, dockware.cc, now resolves.

Did you make sure that your Cloudflare SSL mode is set to Full (Strict)?


now it works i set it to full script ty so much i wanna kiss you


Ok but i got another. If i dont type www.dockware.cc it doesn’t work. I want it to be able to type like dockware.cc without www

What did you change in the DNS entry for dockware.cc? It was working two days ago.

i dont think so i havent changed anything. Its always been when i type dockware.cc it doesnt work it needs www

I don’t have a screenshot from two days ago, but if I had seen the Error 1000 DNS points to prohibited IP, I would have mentioned it.

You need to figure what IP you have in that DNS record and update it to the correct one.

Do i need to create 2 A records?

No. If you are using those Cloudflare proxy addresses, it explains the error you are encountering. You need to use the adresses of your webserver.

1 Like

and how do i do that?

these are my current settings what do i chnge?

One way to solve this is to delete the A record for your apex name, dockware.cc, and replace it with a AAAA record that uses 100:: as placeholder. Make sure it is set to :orange: and redirect to your www name.

I dont understand i deleted my a record not there’s no a record. Am i supposed to create a AAAA record in the dns, or make a rule?

Both. How do think the rule will work if you don’t direct traffic to Cloudflare?

Do i just put @ for the name?


this is how it looks and it still doesnt work

Was I unclear when I wrote:

Do you see 100:: in your screenshot? I don’t see it. You need to use 100:: in that AAAA record.