Encrypted SNI not active

While using Firefox 88.01 if I go to Cloudflare ESNI Checker | Cloudflare to test DNS security it shows that my browser did not encrypt SNI. How can I correct ?

Neither mine.

There were some bugs in between too when running Anti-Virus programs and etc.

If you are interested into changing the value, kindly do the following steps from the article below:

  1. Open about:config in Firefox address bar
  2. Find option network.trr.mode and set it to the value 3
  3. Find option network.security.esni.enabled and set the value to enabled
  4. Close Firefox and re-open the ESNI Check URL to re-check again

Furthermore, ESNI will be, if already not being in development stage/beta, switched with ECH.

You can read more about it here:

1 Like

The config network.security.esni.enabled is no longer valid for 88 version of Firefox. I tried the Ech settings but I still get “not encrypted” for SNI

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.