Encryped SNI test if failing on Firefox

For a very long time my test on the Cloudflare Security Check website has shown all green marks.
Recently, I started getting an “X” on the “Encrypted SNI” test. I checked all my settings several times and they are all correct. I’m using Firefox ver 85.0

Firefox have moved to a newer version of the draft standard for ESNI, which is now called Encrypted ClientHello. I think Cloudflare are still working on a new implementation, so interoperability is likely to be broken at the moment.

2 Likes

Thanks, Michael. I spent a lot of time looking for a solution. I thought it might be something like this, but I needed to make sure.

If I enable ESNI in FireFox, due to my ESET NOD32, it fails.
If I disable one option in my ESET NOD32, then it works.

This is also familiar issue, so maybe you have the same thing going on?:
https://bugzilla.mozilla.org/show_bug.cgi?id=1566175

Since then, I keep my NOD32 option enabled, and ESNI disabled in FireFox and wait for further development.

This topic was automatically closed after 30 days. New replies are no longer allowed.