Enabling Cloudflare broke our email

dash-dns
#1

Mac Mail reports “Connections to the server “b…com” on the default ports timed out.”

Host support says I can either ask Cloudflare for help “getting the mail for b…com to the server at ****”.

Or, I will need to change the DNS MX record for bigbeartools.com to eventually point to **** (typically accomplished by having a DNS A record for mail.b… pointing to ****, and then the DNS MX record pointing to mail.b…)

Does that sound right?

#2

Try setting the “server” to mail.example.com (Replace example with your site) or directly to the IP address of the mail server.

Mail clients don’t use MX records for receiving/configuring mail.

1 Like
#3

Thank you, Judge.

What is the “server”?

I’ll attach a screenshot of the page I’m looking at in Cloudflare DNS.

#4

You should be able to go into your mail clients settings and change the “server” field for your inbox to mail.example.com.

#5

Unfortunately, our host’s mail settings look like this:

#6

I fixed it by forcing server address for incoming and outgoing on mail clients. However, I also added an A record for mail.bigbeartools.com pointing to the server IP and then an MX record.

1 Like
#7

Your initial problem was that it appears that you didn’t have an A record defined for bigbeartools.com. However your fix is absolutely fine and in many ways preferable to just creating the missing entry as it means if you ever do add a record for bigbeartools.com it may be proxied by Cloudflare.

closed #8

This topic was automatically closed after 14 days. New replies are no longer allowed.