Enable SNI breaks the connection between cloudflare and my server


i have a web app with lets encrypt cert and on the panel of cloudflare is set “Your SSL/TLS encryption mode is Full (strict)”. Everything is wotking perfectly.
The problem is that, If i enable on the IIS the option “Require server name identification”, it will break the connection between the cloudflare server and my web application. Why is that?

i need to add other web application on 443 port with another certificatre on this webserver and this option must be enabled in order to make it work the setup.

any idea?

thank you

What error do you get? I seriously doubt Cloudflare’s proxies do not send the host name in the SSL connection, that would essentially break most sites.

Does your site work if unproxied?

yes, it is working even if unproxied and in both cases, with and without the SNI enabled.

btw, now i retried and it worked. Maybe it was a temporary problem…i have no idea. Is it possible to check logs on cloudflare to uinderstand what happened?

Cloudflare does not have these logs. However if it is working now it most likely was a temporary issue with your server. Cloudflare does support SNI.

Glad it is working now.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.