Enable https to webapplication

ssl
dns

#1

Hi all,

my requirement is i need to enable HTTPS to the domain onboardcustomer.com which has to connect the webapplication http://192.163.9.89:9090/admin/login running on digital ocean.

The url (http://192.163.9.89:9090/admin/login) is the web application using flask

1 ) Using cloudflare i added the site onboardcustomer.com
2) if i add the page rule it will be redirected to the IP address which is completely visible in the browser address bar.

please let me know how to hide the IP address while redirection

vijay


#2

It seems that your domain ist not active on CloudFlare. I can see that you have added NS records for darl and reza.ns.cloudflare.com
but you still have Nameservers from DomainControl in place as well. How ever

The registry shows:

Name Server: NS11.DOMAINCONTROL.COM Name Server: NS12.DOMAINCONTROL.COM

They must be replaced with the CF names servers that have been assigned to your account. Currently dare and reza are backup servers for NS11 and NS12. The CF servers are only used if this two servers fail.

So, first you need to change the NS for your domain at the registry.


#3

Port 9090 isn’t a port Cloudflare proxies.

You could use another host name, not on Cloudflare and then no redirection is necessary.


#4

Thanks Mark,

I made the changes, maybe it might take some time

just a quick question, based on page redirect it will redirect to the IP address. I do not want my IP address to be shown in the URL. Pls suggest how can i achieve the same


#5

Thanks csharff, i made the change


#6

This topic was automatically closed after 14 days. New replies are no longer allowed.