Enable Emails and Gzip Compression

Hello,

I have recently activated my website in CloudFlare and I receive the following notice from my hostiing provider:

You have to configure Netfirms server A record and MX record in Cloudfalre for emails and website to work12:5
For your website to keep working you must update the A record of Netfirms in Cloudflare. Netfirms A record is 66.96.160.138For emails:Point A record of MX to 66.96.140.170 and 66.96.140.171update the MX records:priority: 10 host: recorreba.com value: mx.netfirms.compriority: 10 host: * value: mx.netfirms.com

I don´t know how exactly I have to do this

Also , Pingdom says that I should “enable Gzip Compression” and Expire Headers.

These have already been set up in my hosting and I don´t know if I have to set them up also in CloudFlare, so, again, I will appreciate your help in setting this up.

Thank you very much

Liliana

The email DNS record instructions are inaccurate and not quite compatible with Cloudflare.

  • MX records point to hostnames, but they gave you IP addresses instead.
  • You should have a hostname called mail (short for mail.recorreba.com). This is because Cloudflare won’t proxy email through the recorreba hostname.

Ask your host if you can have a hostname of mail.recorreba.com and what its IP address should be. It sounds like they have a fallback mail server of mx.netfirms.com. If you can confirm this with them, you can add a second MX record. No need for an IP address, as it’s not part of your DNS/domain.

Gzip? That’s a common error from Pingdom. Cloudflare uses Gzip and Brotli. Pingdom will get a Brotli response (yay!), then complain that it’s not Gzip compress (boo!, the Brotli one was better).

Expire headers? Depends on the file, but some services complain just because the expiration isn’t far enough in advance. Pingdom does a terrible job of being specific about errors. GTMetrix and WebPageTest are better about this.

Hi!

Thanks a lot for clarifying. I will be asking my hosting provider

Will this conflict given the fact that my hosting provider enabled them?

Thanks!

I meant "enabled both Gzip compression and Expire headers

No. Like most file handling, Cloudflare is a handoff with whatever settings you have in your account. So Cloudflare may use Gzip again, or switch to Brotli if it’s better.

Hello again!

Here is my hosting provider reply:

" Thanks for sharing the response of the Cloudflare support regarding the MX records, you can ask them to update the MX records to the hostname mail.recorreba.com and point it to the following default IP addresses of our email server.

66.96.140.170

66.96.140.171

Once MX records are updated it will take time to propagate to our servers"

I would so much appreciate your help regarding how to configure all these settings; have everything properly updated and finally have emails also hosted in CloudFlare

Thank you in advance!

Liliana

I don’t know if it’s a translation error, but there’s absolutely no way in the world for you to set IP addresses for their server.

It sounds like all you need is just one MX record for @ that points to mail.recorreba.com and give it a priority of 10. That should be enough to get your inbound mail working.

Hello again,

Sorry for the confusion:
My hosting provider is Netfirms,.com As their support is always in English all I do is copy-paste:
I copy-pasted their feedback to you. In the same way, I copy-pasted what you wrote last time pressuming they would understand exactly what data to provide me with.

I will forward your recent comment to them again. Now, please, I really don´t know anything about these matters, and I would like to be as clear as possible. So if I may ask you in case it is advisable to have the emails hosted in CloudFlare, how should I ask them for this??
What exactly, (which specific data) do I need to ask my hosting provider to provide me with? (just ro rest assured of no misswording on my part)

I appreciate your patience a lot !!!

Liliana

All you need is an MX record like this:

Do that, and that’s about all we can do here.

Ok then, thank you very much!!

Cheers!

Liilana

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.