Embedded videos not visible after activating SSL Certificate


#1

Hello everyone,

This is my very first post in this community.

I started using Cloudflare basically yesterday and I found an issue that maybe someone can help sort out.

I designed and developed my portfolio website, www.madquake.net, and tried to activate an SSL certificate for my site. At this moment the site isn’t under the https protocol, as I cannot see the green lock icon, but the grey icon with the yellow triangle on it.

After I forced the use of https the embedded videos used as a thumbnail on each page simply disappeared. Instead, I see a white space.

I tried to find out what’s the source of the problem, deactivating the lock on my browser and after that, the embedded thumbnails appeared again.

I’m EXTREMELY NEW to this, but I’m trying to learn as much as I can and also optimising my site {this is a good school for me}, but I have no idea of the reason why this happens.

I’m probably describing the problem with the wrong words {as I don’t have completely clear the source of the problem}, but I hope someone will be able to help anyway.

Many thanks for your help

Have a good day :slight_smile:


#2

I think I found the source of the problem, but i definitely don’t know how to sort it out!
Basically I discovered that SSL sites don’t like not SSL contents.

The videos I embed are part of my channel on Vimeo.

I built my site in Wordpress, using a template called “Creative Portfolio by Dessign” that allows you to use the videos as featured images for your page and consequentially as thumbnails on your page. All the thumbnails are actually clickable videos so you can watch them directly on the page.

Problem is that the template asks you just for the code of the numeric video and not the full address. In this way I can’t add the https at the beginning of the address…

Do you know how can this problem be sorted out :face_with_raised_eyebrow:
I really feel stupid atm :sweat_smile:

Thank you again for your help!


#3

What’s your SSL setting on your Cloudflare Crypto page? Is it Flexible, or is it Full?

You mentioned “forcing” HTTPS. How did you do this? The Crypto page has two settings you should enable: “Always Use HTTPS” and “Automatic HTTPS Rewrites.” Try those.


#4

I use a Flexible SSL setting on my Cloudflare Crypto page.

I used the wrong wordings… I used “Always Use HTTPS”. Problem is that doing so I’ll never have https on my site because of theose embedded contents. :frowning:


#5

How about “Automatic HTTPS Rewrites”?


#6

Sorry… problem solved…
I activated “Automatic HTTPS Rewrites” and after that, I can see the green lock on my site and also the embedded contents.

I’m sorry for the mess I caused… I’m really new to this!

And thank you for your help!!!