Emails stopped working after changing name servers

I switched my nameservers for to Cloudflare but when I did my emails stopped working in Outlook (my main mail client) and IOS (my phone).

So I started to try and solve the issues and I checked the DNS settings in Cloudflare. I think they are correct, however, I have read the replies to similar queries here and I don’t understand how this applies to me or what I need to do.

I am a writer, I have no idea how to solve this and so would love it if someone could explain it to me like I was a 5 year old.

Actually, a slow 5 year old who is at the back of the class eating crayons.

Seriously though I don’t know enough to know how to explain the things I have done to solve this problem so I could do with a full explanation if anyone can help.

Thank you so much for looking.

Hello there,
In order to get the emails work, MX record is essential.

I assume you’ve checked this at least:

The above will guide you step by step.

1 Like

Thank you very much for your help.

This solved the issue but then I had the triangle warning next to the MX record that says “This record exposes the IP address used in the A record on, which you have proxied through Cloudflare.”.

I then switched the orange cloud off and a new triangle appeared saying
“This record exposes the IP address used in the A record on Enable the proxy status to protect your origin server. Learn more.”

So I thought I would do the same thing for the A record and then another triangle appeared next to the A record and I had two lots of information.

I kept doing this until the warnings were gone and now my record looks like this:

Is this OK to have so many DNS-only records? There is only one that says proxied.

Thank you so much for your help, it really is appreciated.

Nothing to worry about if that’s for mx record. Read more information on it here:

A record for is set to :grey: DNS only. You need to proxy :orange: it

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.