Emails sending to wrong mail server

email

#1

Emails sending from my organizations website (using a contact form plugin on Wordpress) to emails with that domain name, send to our web host’s mail server. We use G Suite for our emails. So any forms that have been filled out in the past few months on our website have not been received.

Example:

I was told by our web host that email routing in Cloud Flare has to be changed from local to external. I’m not sure where to find that option.


#2

Cloudflare doesn’t manage email. Any issue you see are related to the configuration by you of the DNS settings or of the mail server (or service).

Your accounts end in @gmail.com? If so the free Gmail accounts don’t support custom domains and G Suite accounts only support custom domains without a free @gmail.com.


#3

This is almost certainly a configuration error on the local machine/ at your domain provider. At my domain provider (DreamHost) for example, there is a stub DNS instance that they run which makes sense… but it is not my authoritative DNS. However for my shared hosting plan it’s how they keep track of things… if I wanted to make my local Dreamhost mail be delivered somewhere else, I’d have to change my DNS settings for that zone in my Dreamhost control panel to match what I had in external/authoritative DNS.

If you have a virtual server you’re running you may instead need to make a change to your local SMTP virtual server… but neither of these is Cloudflare. As @matteo mentioned Cloudflare doesn’t host email and there is no such thing in authoritative DNS as “local or external” email routing.


#4

Thanks for the reply. Yeah, I that’s what I thought. We use BlueHost for our website, but the support agent said the issue was that it was routing our emails to our domain locally and that Cloudflare was causing that issue. I wasn’t even sure what that meant because it didn’t sound right.

We have G Suite for non-profit. So all of our emails use gmail but have our domain. Everything works fine on that end.

It’s only when sending an email through a contact form on www.ridgeway.church to a email address ending in @ridgeway.church that it goes to our old Bluehost email servers. Otherwise it will send properly to a regular gmail address that doesn’t use our domain.


#5

Looks like my old thread might help you out here!


#6

I would agree with @cscharff here. G Suite for non-profit still uses your custom domain, it uses the Gmail interface, but not that domain unless you resend all incoming messages to a personal one of somebody.

Your Cloudflare configuration it’s fine, it works even though it misses an entry (of the 5) in the MX records (they are personal to each account, so you need to go to your admin.google.com and check).

I assume that the MX records for ridgeway.church inside your server point to localhost. Try doing a lookup of DNS from the server itself (I assume it’s Linux, so from the terminal/command line -> dig MX ridgeway.church).


#7

This looks promising and is my exact issue. I’ll have to check and see if I can get that to work.


#8

Basically my take then. @sdayman beat us all with that take 6 months ago!


#9

Yes, @sdayman worked it out!!! It was puzzling me for a while but I get it now :joy:

Hope it helps @connor.betts as well :slight_smile:


#10

Thanks for all your help! I’m normally pretty good with figuring this stuff out, but it’'s also not my area of expertise, so I was having some trouble understanding your responses. Working at a small non-profit I end up wearing a lot of hats.


#11

Also, since you mentioned GSuite for non-profits, your org might qualify for Project Galileo, depending on the nature of what your non-profit does and how at-risk it is :slight_smile:


#12

I looked into that. We’re just a small church. So from what I could tell we wouldn’t qualify. Thanks though!


#13

Did that old thread of mine solve your email issue?


#14

I was just able to test it. That was the issue, it works now! This was so frustrating. Thanks for helping me out!


#15

No problem! It’s good when someone else here has had the same issue :slight_smile: