EMails not working due to DKIM?

I noticed that i wasn’t getting emails via my host provided email. After opening a support ticket with them, they said that the DKIM via my cloudflare had to be updated.

Problem is, I have absolutely no idea what needs to be updated. They gave me a string of text and I pasted that into the DKIM section and I’m still not getting emails.

How do i figure out what needs to be entered for this field to get my email working?

Please post a screenshot of the DNS record you entered here.

v=DKIM1; default._domainkey.harrisancestry.com. TXT v=DKIM1; k=rsa; p=MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEA3vY1smk2xr6LWQ9bgZbK62YDuHfQkgLSg3/Ql0Ah0favcGAe9WBoS0v+t1VucaSLccs/qqqw+ejEB06kiMQ0eYpjztzosnxEato7ZRD/qMMnbdsXJNy8r0SUq4dsE2nYx8bbEquyX77vF5KRldqKCcrmof1w2ZHnkimMKm83z0KCaDefjsZzUkMD8lkoqMG+P+MOUqVTXN2REhaRe+cOWgNb05Zk5bSBJh0J700ovIIt1WfGd9a38wGR00i4wr6o43aDgb0m7km0NPtrEJ6v0f4JQjMF9Z9dmn/4/JscAM9IduC0V18yhZIy6R2kaXXBlPuRSf9ZyDgUpPUxqHx54QIDAQAB;

This is what the web host sent me

On checking, it seems that the issues to be caused due to invalid DKIM record, Please refer below:

[[email protected] ~]$ dig TXT default._domainkey.harrisancestry.com

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.68.rc1.87.amzn1 <<>> TXT default._domainkey.harrisancestry.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 57582
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;default._domainkey.harrisancestry.com. IN TXT

Since the domain DNS is managed by Cloudflare, You need to update the DKIM record mentioned below from your Cloudflare dashboard

default._domainkey.harrisancestry.com. TXT v=DKIM1; k=rsa; p=MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEA3vY1smk2xr6LWQ9bgZbK62YDuHfQkgLSg3/Ql0Ah0favcGAe9WBoS0v+t1VucaSLccs/qqqw+ejEB06kiMQ0eYpjztzosnxEato7ZRD/qMMnbdsXJNy8r0SUq4dsE2nYx8bbEquyX77vF5KRldqKCcrmof1w2ZHnkimMKm83z0KCaDefjsZzUkMD8lkoqMG+P+MOUqVTXN2REhaRe+cOWgNb05Zk5bSBJh0J700ovIIt1WfGd9a38wGR00i4wr6o43aDgb0m7km0NPtrEJ6v0f4JQjMF9Z9dmn/4/JscAM9IduC0V18yhZIy6R2kaXXBlPuRSf9ZyDgUpPUxqHx54QIDAQAB;

And please confirm that the name servers at the bottom of your DNS page are Mack and Ryleigh.

image

For the third time:

Screenshot. Not a cut and paste.

1 Like

You entered it as harris._domainkey

It should be entered as exactly: default._domainkey

Value of:
v=DKIM1; k=rsa; p=MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEA3vY1smk2xr6LWQ9bgZbK62YDuHfQkgLSg3/Ql0Ah0favcGAe9WBoS0v+t1VucaSLccs/qqqw+ejEB06kiMQ0eYpjztzosnxEato7ZRD/qMMnbdsXJNy8r0SUq4dsE2nYx8bbEquyX77vF5KRldqKCcrmof1w2ZHnkimMKm83z0KCaDefjsZzUkMD8lkoqMG+P+MOUqVTXN2REhaRe+cOWgNb05Zk5bSBJh0J700ovIIt1WfGd9a38wGR00i4wr6o43aDgb0m7km0NPtrEJ6v0f4JQjMF9Z9dmn/4/JscAM9IduC0V18yhZIy6R2kaXXBlPuRSf9ZyDgUpPUxqHx54QIDAQAB;

okay, i’ll make the change and test. I appreciate your help.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.