Emails not sending / receiving

Hi all, I have read lots of posts on this, but sadly cannot fix it, so I am hoping someone can tell me where I am going wrong here

I just need Cloudflare for the website, so I have changed name servers and it all works really well, apart from emails.

Here are my settings:

Thanks for your time

Hello there,

A couple of things need to fix:

  1. Your A records are not proxied.
  2. Have you added MX records
  3. Ensure you’ve set the basic set up correctly
1 Like

Ohh, I thought I had to have them not proxied so they used my hosts settings?
Is this better? Thanks so much for looking into this for me

MX records are very necessary for the email to function. Please check if you have them one.

I have added two MX records, one for incoming and one for outgoing mail servers, is that correct?

Ahh, I have removed those and added one with mailserver.domainname. co. uk as that is what it says it is in my fasthosts account

You can verify them with the host provider, should be as it is.

This is what I have now

And here is what Outlook says:

5

If your mail client is trying to connect to a :orange: proxied hostname, that’s your problem. The Cloudflare proxy is for for HTTP and HTTPS. Other protocols, such as those used by email, require that you set the hostnames to :grey: DNS Only.

3 Likes

I have set everything apart from the website to be not proxied, still not working, not sure what the issue is :frowning:

@user89811 From the screenshot you sent, I see the MX records that has an issue. Please fix that one. Get the MX records from the hosting provider. For more guide read this doc.

1 Like

Try unproxying the website as well, then give it five minutes to take effect.

Hasn’t worked, so I deleted the mailbox from Outlook and now it won’t set back up, I am going to change the mailbox to an exchange mailbox and see if that helps.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.