Emails not arriving

Hi guys, I’ve 4 websites running Cloudflare and a new one on the way so first of I’d like to appreciate all the good work that it’s been done with Cloudflare and how much this community has helped me in the past years, where I’ve lurked for answers while not being a registered user. However, today I had to create my own account and first topic because of the following issue:

We’ve a new website, which we setup our DNS Records according to what our Zone Editor shows in the cPanel, but something weird happened with the emails, and nothing seemed to arrive, until we turned off Cloudflare.

We’ve a A record named “webmail” in :grey: and a CNAME record named “mail” also in :grey:. As it’s a website with many many years, I haven’t made a lot of questions as why this records exist as they are, and we haven’t created any new MX record as no MX related to mail is shown in our Zone Editor. Still we would like to know how we can fix this so that we can enable Cloudflare and receive emails.

Thanks in advance!

Hi @Casprom and welcome!

You will need an MX record in order to receive mail, what’s the domain?

1 Like

Hi @domjh, can you see the hidden detail text bellow? I shared the domain in there as it would be best not to disclose it publicly.

Yes, feel free to edit your post to remove the domain if you don’t want it public.

The MX records are currently these:

20 mx2.cleanmx.pt.
10 mx1.cleanmx.pt.

You’ll need to add those in Cloudflare’s DNS for emails to work when you change the nameservers.

1 Like

We’ve those MX records already in Cloudflare too, with their names being the domain. :sweat_smile: So apparently we’ve also the MX records setup along with the CNAME and A record as mentioned before. So why are the emails still not working when Cloudflare is enabled?

I clearly misunderstood. I thought by this you meant you didn’t have any MX records.

I see those records on Cloudflare nameservers as well.
What exactly doesn’t work with your emails? Error messages and screenshots are helpful.

1 Like

There’s no error message, the emails simply won’t arrive to our mailbox. We tried sending test emails from our personal emails (not from this domain emails) to all of the emails on this domain and none would arrive. We didn’t get any message claiming any error sending them but we kept checking that no new email ever arrived to our mailboxes. As a press website we receive dozens of communications every hour and we simply stopped receiving any new emails. There’s no error message, the emails simply won’t arrive to our mailboxes. So we disabled Cloudflare and reverted to the original name servers and all the emails that didn’t arrive before came through and appeared.

That is very strange. You could try pausing Cloudflare and see if it’s caused by something that is proxied. If that doesn’t work and all your DNS records match then you’ll need to reach out to your mail host for assistance with troubleshooting this.

Ironically I am having exactly the same problem with my domain. It’s been working successfully through Cloudflare for years. Then my hosting provider was acquired by Crazy Domains in November 21. Just last week however my email suddenly stopped working. I also go through cPanel (Plesk) but I have another domain which doesn’t go through Cloudflare on the same account which is working fine.

At this time I cannot tell which system is at fault, Cloudflare or Crazy Domains. What I can say is that Crazy Domains tells me to talk to Cloudflare and refuses to investigate further because it’s “not at their end”. Sigh.

Sounds to me like your e-mail client was configued to use proxied :orange: domain.com instead of unproxied :grey: (DNS-only) mail.domain.com for POP3/IMAP/SMTP.

I’d suggest you to double-check and set the “E-mail Routing” to “Remote/External” as far as you are using different e-mail provider? so cPanel would respect and treat the DNS “as-is” like that, instead of “local”, just in case (had issues with it on 3 domains).

  • even on cPanel upgrade, it reverted back to “local” instead of the set “remote” for “E-mail routing”

Make sure DNS records (MX) at Cloudflare for your domain(s) containt correct hostname (value).
Double-check which receiving/sending servera is your e-mail client using.

Otherwise, the SSL certificate expired?, and if it cannot be renewed via AutoSSL as far as it tries to renew it for www, non-www, mail, and any other sub-domain, if one hostname fails, the new SSL certificate will not be issued via cPanel (AutoSSL/Let’s Encrypt).

  • If that’s the reason, then as already suggested, temporary use the option “Pause Cloudflare for this site” from Cloudflare dashboard, wait for 20mins, try to renew SSL, upon success, deactivate this option
1 Like

I just resolved the issue, by disabling the proxy in Cloudflare for the A record mail.{domain} in my case.

Moments later I was advised to do the same thing by Crazy Domains support.

1 Like

It appears I spoke to soon :frowning:

While I suddenly got a bunch of emails after disabling the proxy, some of them were from today, but some were from the past 3 days when it supposedly wasn’t working.

Now however I am not receiving any of my test emails again. This is really frustrating. Dare I use the “i” word… intermittent :hushed:

I’ll give it some time for the change to propagate, might just be that.

Ok got it now… my MX Record was setup incorrectly as;

Name = "mail", Mail Server = "mail.{domain}"

When it should have been;

Name = "{domain}", Mail Server = "mail.{domain}"

1 Like

I’ve been quiet for a few days trying to work this out and test it but again the emails stopped coming, like I said before the webmail A record and the mail CName record are :grey: and the MX records are just the same as @domjh mentioned :disappointed_relieved: I don’t know what else to do.

I paused Cloudflare and the emails came through. So it must be something that shouldn’t be proxied right? What if the “webmail” A record should be “‘mail” instead just as CName is named “mail”? Although in the CPanel Zone Editor it says webmail to A and mail to CName :sweat:

This post was flagged by the community and is temporarily hidden.

Hey guys,

Just a check up:
This issue was solved by contacting with our host and for some reason they said they readjusted things on their end so we didn’t had to change anymore configurations on Cloudflare :sweat_smile:

Thank you everyone for trying to help.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.