eMails get lost after CDN is enabled

Hi,

here’s my setting: WordPress Page hosted on uberspace.de, Domain is registered under namespace.com. WP Caching (and CDN settings) are managed by WP-Rocket(.me) Plugin. E.g. Global API Key, admin mailaddress and Zone ID are stored there: Using WP Rocket with Cloudflare - WP Rocket Knowledge Base

Namecheap is set to custom DNS pointing to Cloudflare DNS:

Cloudflare has following settings:

e.g. only the main domain is covered by CDN, stats.inua.academy is running a Matomo, connected to this page. The MX/SPF settings are as supplied by uberspace.de:

The mailserver's configuration has been adapted.
Now you can use the following record for your DNS:
  MX  -> arche.uberspace.de.
  TXT -> v=spf1 include:spf.uberspace.de

Same settings on namecheap work like a charme, mails are properly received (e.g. forwarded). The minute I engage Cloudflare CDN no mails come through. What did I do wrong, which setting did I miss?

best regards Stefan

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.