Emails are not forwarding to any Gmail email accounts

Emails are all forwarding to my Hotmail account but not Gmail accounts.

I am getting the following Reverse MX A records (PTR) message:
ERROR: No reverse DNS (PTR) entries. The problem MX records are:
17.205.159.162.in-addr.arpano reverse (PTR) detected
… and more like this…

This is way above my head to resolve and I would really appreciate your help.
Thanks.

I would like to quote this from Reverse DNS Resolution - No PTR Record found:

In other words:

PTR checks based on MX records are solely made on assumptions, and cannot exactly be called a reliable “test”.

As the output you quote indicate that the PTR checks are based alone on the MX records, you should just ignore them.

I guess you will have to look at your problem somewhere else. Perhaps some (if not all) of it may be found over here:

That being said, -

The “Activity Log” (Magic Link: https://dash.cloudflare.com/?to=/:account/:zone/email/routing/overview) may, for a limited amount of time after the delivery attempt, be able to provide more informative information about why some of your emails are not being forwarded (e.g. if they are being rejected by the final destination, and if so, the status code and reason the final destination provided while rejecting them).

Thanks for the response. Please keep in mind that I am the owner of YOYA.
I am a business man and not at all a tech savvy individual. I’m a new client and I just ended my CDN services with StackPath CDN because they are no longer offering CDN services.
I read good reviews from your company but I feel that your support services does not provide any “live support” (phone or live chat).
Not being a technical person is making it hard for me to resolve an urgent situation.
I rely a lot for my clients to receive emails after they purchase from our website.
Clients with a Gmail email and even my staff that need emails forwarded to personal Gmail emails are not getting them.
Can I just use your CDN services and not have you (Cloudflare) not handle our emails and just let Bluehost handle all our emails instead?
I would love to continue to do business with you but I need for you to contact me asap to fix this issue. Sincerely,

Alain Verdier - Co-Founder
YOYA

Phone and Live support are certainly available… but require the appropriate plan. If you didn’t check what’s on offer before signing up (as most people sadly don’t bother to do), perhaps better late than never: Our Plans | Pricing

That said, there are a lot of highly experienced and very helpful people here in the community forums who can help you… but you need to provide adequate information before anyone can help you.

To begin with, what is your site address – the domain name you set up in Cloudflare?

Can I just use your CDN services and not have you (Cloudflare) not handle our emails and just let Bluehost handle all our emails instead?

You can, and that’s, in fact, the most common setup.

If you could share the domain name in question, I could look it up to see what may be going on.

shopyoya"."com

@averdier:

There would be at least two things you should do, considering how your set up looks like from the outside:

  1. Disable the Proxy status for the A record named server, making it become Unproxied (:grey:) / DNS-only.

  2. If the MX record with the name shopyoya.com doesn’t already have the Content / Mail server (required) field set to “server.shopyoya.com”, then change it to become “server.shopyoya.com”.

In addition, I would however also:

  1. Remove the “+a +mx” part from the TXT record with the name shopyoya.com, that starts with “v=spf1”, and preferably, change the ending from “~all” to “-all”.

Thanks for your response.
Does all the above recommendation have to be done from Cloudflare or Bluehost?

Here is also the return message I get after I sent my test email:

Here is also what I got from IntoDNS:

Here is my DNS settings for BlueHost:

Here are my settings for Cloudflare:

Thanks for providing all the information above, once you have all the details in your hands, it does indeed makes it easier to help / suggest what to do!

  1. Disable the Proxy status for the A record named server, making it become Unproxied (:grey:) / DNS-only.
    → Record #2 from your Cloudflare screenshot above.

  2. Disable the Proxy status for the A record named mail, making it become Unproxied (:grey:) / DNS-only.
    → Record #5 from your Cloudflare screenshot above.

  3. Contact Bluehost, and ask them to change the Reverse DNS (PTR) record for that IP address to become either “mail.shopyoya.com” or “server.shopyoya.com

Once all the changes have been successfully coordinated, it could take a while (e.g. expect minimum 24-48 hours) where the issues may still appear due to DNS caches (and local ISP policies) here and there.

But once the changes mentioned has been made, things should start (even if slowly) to become successful again, if they were before.

Since your domain is now connected (with it’s name servers) to Cloudflare, it would be through Cloudflare you should make the above mentioned changes.

#3 from this specific post, about contacting Bluehost about the Revere DNS (PTR) record will the only one that requires Bluehost’s attention.

If you get all that successfully effectuated, you can both use Cloudflare (with Proxied (:orange:) records on your apex / “naked” domain, as well as the www), without it should interfere with your mail traffic in any way, under the condition you keep the Proxy status of the other records mentioned above set to Unproxied (:grey:) / DNS-only.

1 Like

Is this correct?

Do I still need to do this part?:

  1. Remove the “+a +mx ” part from the TXT record with the name shopyoya.com , that starts with “v=spf1 ”, and preferably, change the ending from “~all ” to “-all ”.

That part is correct, yes.

That would be my recommendation.

a” is literally authorizing Cloudflare’s HTTP Proxies to send mail on behalf of your domain, since the apex / “naked” domain is Proxied (:orange:).

mx” is literally saying “look up the MX record, then look up the A record”, which will literally point to the highlighted IP address in your screenshot.

Since you already have that highlighted IP address listed with the “ip4:…” mechanism, any sane SPF validators should complain about your domain, for having authorized the exact same IP address multiple times.

As for the “~all” versus “-all” part, that would also be what I would recommend.

The SPF record would, as always, need to be adjusted if you either add or remove email providers, which need to send emails on behalf of your domain.

So I will replace this:
v=spf1 ip4:162.241.180.246 +a +mx ~all

To this:
v=spf1 ip4:162.241.180.246 -all

Correct?

Yes, that is correct.

Note: The Bluehost (#3 above, re. Reverse DNS (PTR)) still does not appear to have been adjusted.

Hi, I am still having issues with my emails not reaching Gmail email accounts.
Is this a “Reverse DNS” issue?
Here are my DNS settings at this time:

Actually, I just want to use Cloudflare CDN services ONLY.
Can I just stop my domain pointing to Cloudflare and just use Cloudflare API token instead for my Wordpress website?
It seems to be to troublesome to make this work the way it is setup right now.
Thoughts?