Email service hijacking my MX domain

So I recently decided to give the email service a try. While it seems nice for some use cases, it didn’t quite meet what I was looking for so I decided to disable it and start running my own mail server. After setting everything up and not having any issues with MX records for a week, I noticed that Cloudflare started automatically adding the MX record for their service, despite the service being disabled (and had been disabled for a good week). As a result, Cloudflare hijacks my MX domain from my managed email service.

Anyone else experience this?

What is your domain?

1 Like

Currently, looks like none MX or A record found for it.
From DNS history, I could find some from Cloudflare and DigitalOcean.

May I ask have you tried looking into the Account → Audit Log for some details what event has happened and for some more additional information? :thinking:

I’m not sure what you’re looking at but there are definitely records there.

The 10. address is the one that’s being added by Cloudflare. The 174. address is the one from my cluster in digitalocean. I’ve tried deleting the 10. address, but it just keeps coming back.

Unfortunately, from the above screenshot you shared, those are the two A type records and not MX type records.

It’s a difference.
A is not the same as MX

You’d have to adjust your DNS records.
Firstly, remove both A mx.
Secondly, add new MX type record pointed to
Therefore, add new A type record mail pointed to the IP and :grey: (DNS-only).

Usually, the MX record should point to a hostname such as mail , and the A (or CNAME ) type record for that hostname should be set to :grey: (DNS Only).

May I suggest checking below article if your e-mail records (usually the A mail and the MX record) are configured properly while you are using Cloudflare for your domain name:

Helpful articles about managing DNS records at Cloudflare:

Ah! the 10. address isn’t being added by Cloudflare. It’s an internal IP thats leaking through. I think I know what’s going on.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.