Email routing - wildcard MX - broken after update

In the past I’ve been using Cloudflare Email Routing for all subdomains of my domain (excluding the root domain).
The dashboard displayed that the DNS records were incomplete, but the emails were still being routed.
After the most recent update, this functionallity broke and now “Email Routing is currently disabled and not routing emails.” is displayed.

Attached is the configuration that worked before but does not now:

PS.: I don’t want to route the emails of my root domain through Cloudflare due to privacy reasons.

1 Like

Are or were you on an Enterprise plan? Email routing for subdomains is only supported on an ENT plan.

Wildcard DNS records can have some strange behaviour. One is that wildcards only get used if no other record exists with that label. It’s possible the DNS records were fine until you created another record, such as an A record covering the root of the domain.

No, not currently nor ever been on a enterprise plan, and until recently, it worked like a charm.

I guess I’m lucky that I didn’t create to many accounts with subdomain emails then ^^

Did you recently create an A record for the domain root?

No changes at all, except the passing of time :confused: