Email routing Syncing status is stuck at "Syncing", cannot receive emails

My syncing status is stuck at syncing and I cannot receive any emails.

I’ve tried to fix this. I disabled Email routing and chose to delete all relevant DNS records.

Then, I re-enabled Email routing and it auto-added the relevant DNS records.

However, it is still stuck on “Syncing”.

Cloudflare is taking care of routing email messages only, and does not provide any accounts for you to use in e.g. email clients.

It sounds like you would need to talk with your email provider, and ask them for the correct mail server details (e.g. SMTP and IMAP), to use for your email account.

Where exactly does it say “Syncing”?

Can you eventually provide a screenshot of that?

I created email routing, but the Routing Status in Email Routing configuration summary page stuck at “Syncing” for almost two hours. Is there anything I can do to get the status out of “Syncing” to make email routing work? Thanks.

I am also having the same issue, email routing is stuck at “syncing”. The logs below also shows that the result of the email routing is “forwarded” but I don’t receive the email.

Finally the Routing Status changed to “Enabled”, and I can receive the emails routed through Cloudflare. It seems that all I need to do is just wait - wait for the system to finish sync.

1 Like

I’m having the same problem right now. In the screenshot below, you can see where it says “Syncing”. If you hover this badge, it displays “Email Routing is enabled, and it’s syncing with Edge. Your emails will be routed after it’s synced.”

1 Like

I am having the same issue on a domain currently. Here is a topic with the same problem.

Here is an answer from a topic about the same problem:

Apparently, you just have to wait for some time until it gets enabled. I also checked Cloudflare Status ( but there are no outages right now.

I must admit that I’ve never seen it be (or stay) at “Syncing” like in the screenshot.

So from OP’s initial post, I was, as mentioned thinking it was an email client (e.g. Thunderbird, K-9 Mail, or so), likely due to some sort of incorrect configuration or misunderstanding of how the Email Routing would work.

For that extended information (including the other thread), I’d go as far as to say the same as mentioned here:

Other people have seen 550 5.1.1 Domain does not exist email rejections for a (little) while, while the configuration have been syncing to the edge.

I would go as far as to say, that the Routing status “Syncing” is supposed to indicate that this syncing is still is ongoing, and that you need to wait for that to succeed, instead of just expecting that the inbound email routing would work right away.

1 Like

Mine ended up changing to “enabled” but I am still not receiving any emails. After awhile Gmail sent back the error:

The response from the remote server was:
451 4.3.0 No available upstream. lkNg882xialc

I have tried using the custom address as well as the catch-all feature that Cloudflare provides. Both does not work. I have tried another email forwarder’s catch-all feature and it works perfectly so I assume this is an issue with Cloudflare.

1 Like

What exactly does the Activity Log say (including when you expand each item)?

Cloudflare doesn’t show that it’s receiving the emails. Activity log is empty and the Total Received under Email routing summary remains the same.

Mind sharing the custom domain[1] you’re using, and what the domain of the email address of the final destination[2] is?

E.g. if [email protected] is routing to [email protected], I’m looking for both random.example[1] and[2].

It can sometimes take a moment or two, before it shows up on the Activity Log.

Sounds weird though, that they would stay empty, … does the same appear for the others numbers (Forwarded, Dropped, Other), or are any of them actually raising? catch-all is routing to my mail server at [email protected].

One thing I noticed is that if I change the destination to a yahoo email, the forwarding works fine. But if the other email forwarder (simplelogin) works with my mail server, I don’t see why cloudflare doesn’t work.

The other emails in the Activity log has since been cleared and is now empty but previously they all said Forwarded when it routed to the yahoo email

1 Like
$ dig A
;; ANSWER SECTION:      3600    IN      A
$ dig MX
;; ANSWER SECTION:      3600    IN      MX      10

MX records must point to a host name, not to an IP address.

Try pointing the MX record to “” instead of “”.

Oct  3 05:23:06 mail postfix/smtp[481344]: warning: numeric domain name in resource data of MX record for

Ah so that was the issue. Great everything works now, thanks a lot!


Looks in this case like Cloudflare may not be falling back to the direct A/AAAA record(s), if the MX record(s) aren’t formatted properly, or otherwise defective.

A couple of other issues, at least, if you send messages directly from that machine:

  1. Reverse DNS (PTR) for the IP address is currently, which looks dynamic/generic.
    → Ask your provider, MyRepublic Ltd., to change it to “”.

  2. TXT (SPF) record for “” is currently “v=spf1 a mx ip4: ~all”.
    Since the MX record literally points to the A record, that again points to the mentioned ip4: directive, you’re literally authorizing the same IP address three times.
    → At the bare minimum, remove “a” and “mx”.
    → Preferably, also consider the strictest policies, where possible, e.g. “-all” instead of “~all”.

#1 will definitely cause email rejections, if you send messages directly from that machine.

Haven’t yet seen rejections for #2 (e.g. duplicating content) though, but that could just be a matter of time, before mail server admins might start with additional sanity checks there as well.

Happy to hear that! :slight_smile:

You’re welcome :slight_smile:

1 Like

hey, sorry about the delayed response.

here’s the screenshot:

my email provider is gmail, and I use email routing only for routing incoming emails. the last time i configured it was last year, and back then, it didn’t require me to communicate regarding the same with my email provider.

I also have the same issue. It’s been like this since 8+ hours.