Email Routing does not allow for emails with plus sign

Regarding the Email Routing Beta

I’ve registered my [email protected] as catch-all email.

The validation email was sent to [email protected] and the forwards are sent to [email protected]. the +spam part is completely ignored.

My plan was to use the +spam as the email for the catch-all option.

A post was merged into an existing topic: Support plus addressing in email routing