Email Routing Disabling + Google Workspace Problem!

So I have created a google workspace account with a customer email address that I need to connect to my domain. I tried to connect but I received an error saying “The record is managed by email routing. Disable Email Routing to modify/remove this record” as shown in the image. I have disabled email routing as instructed by the error and as shown in image one, but the connection failure still gives the same error. Also, there is no way of removing the remaining 3 DNS files to allow for connection. Please HELP!!

Are you still encountering this issue? I see ticket 2504451 and have seen a similar report or two, I will escalate this for the team to review. Bug removing MX records was the similar post as this.

The google MX records are in but are still in a state of conflict, so I still can’t receive emails it seems. I need the others to be completely removed so as to receive emails through google workspace. Thank you for replying btw, it gives peace and hope. If I make another ticket they will just cancel it. Help me resolve this issue. Thank you Cloonan

These are the required records that may be causing the problems, the probably need to be deleted or sorted in a way.
The top error part that you wont see in the image says.

“Email Routing records are not configured. There might be some conflict or missing records. Configure the records to make sure Email Routing works properly.”

I am also afraid that if i enable email routing it might cause a problem

This post was flagged by the community and is temporarily hidden.

Hello, this problem hasn’t been solved yet!