Email Routing and Fastmail

Today i tried to configure my domain to work with the Fastmail e-mail service. It does seem to work as intended but I stumbled across the Cloudflare Email Routing settings page. The routing status is listed in the configuration summary as enabled without having activated it. Furthermore, the page lists the Email DNS records as misconfigured. On the setting tab however routing seems to be disabled. The Fastmail entries are listed as conflicting records.

As I just want to use the Fastmail service and am not planning to use the routing service, I wonder whether I made a mistake in the setup. How can I ensure that email routing is not enabled?

Additionally, I wanted to ask if it is really correct that I cannot change the Cloudflare nameservers of the domain bought on Cloudflare to point them to the Fastmail addresses (

If you’re not using Cloudflare’s E-mail Routing, you don’t need to configure the records for it. You need only add the relevant DNS records that FastMail is telling you to add — Manual DNS configuration – Fastmail.

If your domain is with Cloudflare Registrar, then yes, you need to use Cloudflare’s nameservers. But again, just manually add whatever FastMail records you need, with exception of their NS records.

One other note: You’ll likely want to ensure the FastMail records are unproxied (gray-clouded).


@ jwds1978: Thank you for your reply. Is there any reason why the routing status could be listed as enabled in the configuration summary?

Offhand, not sure. But realistically though, if you don’t have the Cloudflare Email Routing DNS records configured, it’s not doing anything anyhow. Without seeing your DNS records, I’d assume the dashboard is showing “Email DNS records misconfigured” because you’ve setup FastMail’s records instead of Cloudflare’s, which should be what you want.

Have a look at Email Routing settings page · Cloudflare Email Routing docs for information about disabling Email Routing.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.