Email not working since switching on Cloudflare

I switched on Cloudflare last night and the website is working fine, but I am unable to send and receive emails from my Mail Client. I can from Webmail though.
What have I missed?


Change your mail CNAME record to an A record and point it to the same IP address, leaving the proxy icon at :grey:.

Changed that.
Still doesn’t seem to be working :frowning:

Which hosts does your mail client use?


So should I change the MX record to that rather than

No, the MX record is fine, you need to change the left settings to mail..

Sorry, the settings on the left?
Do you mean I need to be using the non SSL settings for my mail client?

Yes, well, not the port numbers but the host.

It doesn’t like that. It’s timing out.

You changed both to mail? No timeouts for me and works too. Can you post a screenshot?

It’s working fine now. Thank you.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.