Email Not working After Switching to Cloudflare

Hello everyone

I switched to Cloudflare 2 days ago, and everything was fine until that I’ve noticed that I’m not receiving emails from my website. I’ve watched the tutorial video, and I’ve applied all the tips that they asked, but my problem wasn’t resolved.

Here is my DNS configuration

Try changing pop, smtp, and imap to :grey: as well.

Hello Sir, thanks for your answer

Sadly, it didn’t fix my issue, and each time I try to send a test email I get this error.

There was a problem while sending the test email.

Could not connect to the SMTP host.

This means your web server was unable to connect to “mywebsite”.

Typically this error is returned for one of the following reasons:

-SMTP settings are incorrect (wrong port, security setting, incorrect host).
-Your web server is blocking the connection.
-Your SMTP host is rejecting the connection.

Recommended next steps:

  1. Triple check your SMTP settings including host address, email, and password, port, and security.
  2. Contact your web hosting provider and ask them to verify your server can connect to “mywebsite” on port 465 using ssl encryption. Additionally, ask them if a firewall or security policy may be preventing the connection - many shared hosts block certain ports.
    Note: this is the most common cause of this issue.
  3. Contact your SMTP host to confirm you are using the correct username and password.
  4. Verify with your SMTP host that your account has permissions to send emails using outside connections.

I don’t know what you’re trying to connect to, but if it’s one of the 104.219.248.91 hostnames, it’s really slow. It takes ~20 seconds. The SMTP test I ran from mxtoolbox.com timed out after 15 seconds.

So, what should I do in this case?

Talk to the mail host about the difficulty you’re having with sending mail.

Do you think that my problem will be fixed if I change to another plugin?

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.