Email not routing

Just received access to the Email Routing feature of Cloudflare on my domain https://buybestindia.xyz/

I have created one custom address and have fulfilled all the requirements.

But while trying to send a test mail. it says

The response from the remote server was:
550 5.1.1 Domain does not exist

Could you please share the domain you are using?

If you prefer I can help debug privately on Cloudflare Developers

I’m seeing the same issue. Just like OP one of my domains (gloriouspenguin.com) just got access to email beta, very recently, few hours ago, and the forwarding does not work with “Domain not found”. The fix described there did don’t help (I did wait 5+ minutes after toggling Catch All back): How long for Email Routing to get set up? - #10 by sven2

I’m wondering maybe I should wait 24 hours following enablement of the feature on the account and then try again?

Thanks, we are looking into it

1 Like

We found an issue that prevented the rules from syncing to our backends, which has now been fixed. The next time you “touch” a rule (make a rule modification), it should properly sync. This should now be fixed for both of these domains.

4 Likes

Thanks for the solution! It seems to work now :slight_smile:

For other people reading this thread:
The “rules” @oli is talking about are the “Email Routing (beta)” settings.

Confirmed, it is working now. Thank you very much for quick support and glad the bug was found and fixed!

@oli, @sven2 I’m seeing the same issue with saspus.com. Can you please check?

Final-Recipient: rfc822; [email protected]
Action: failed
Status: 5.1.1
Remote-MTA: dns; linda.mx.cloudflare.net. (172.65.14.34, the server for the
domain saspus.com.)
Diagnostic-Code: smtp; 550 5.1.1 Domain does not exist
Last-Attempt-Date: Sat, 22 Jan 2022 18:15:07 -0800 (PST)

(I’ve reverted the MX records for now to restore mail deliverability)

1 Like

I am also encountering the same issue.

As like all the others, please post your domain name.

Hi, I would prefer to not post it in the open to a support forum. I am happy to share the domain with you privately if that helps.

It’s a domain name. It’s public information. The whole point of a registrar is to make this name publicly accessible. Hiding it on the forums is therefore pointless.

You can send it to sven2 over at Cloudflare Developers

sorry it was an issue on our side. I manually enabled your zone, after you toggle the catch-all rule (or touch any other rules) it should start working.

2 Likes

Confirmed, works now. Thank you very much for such a quick response and especially on the weekend!

Hello,
I added another email address to my domain which is hosted in Bluehost and connected to Cloudflare in hopes it would clear up the issues of autoresponders and newsletters from my testing in GR not sowing up in my Google mail. I notice some items in the settings for my Cloudflare possibly need attention. sven2, are you able to help me?

Which settings? There’s not much to set for the email routing beta feature. It requires a few DNS records, and a verified destination email address.

Done :slight_smile:

1 Like

The MX which is DNS only, is indicating that the IP address is exposed. I first set this up 2 yrs ago according to the note attached to MX record. I haven’t done anything since and I noticed that on the left there is BETA next to where it says Email. Anyway, I have an email connected to my google account email where I receive my notifications of actions on testing of autoresponders and newsletters. This process has not been working as it should over the last week or so.

I am having same issue

My mail is not routing correctly.