Email not received no matter what

Hello,
I have been struggling for almost a month to solve the email problem.
It neither receives nor sends emails.
My hosting is Contabo, OS i use CWP7pro Control WebPanel.
i use Cloudflare as DNS.
Routing is disabled in Cloudflare.
I need emails to work on [email protected]
I use the default Roundcube.
Below is all settings i have:

Please tell me the errors and how to solve the problem.

Please tell me what to change or what to add and where to do it.

Sorry for the question, I’m new to all this and it’s very hard for me.

I hope someone help me solve this problem.

Kind Regards

Contabo: Reverse DNS Management

DNS Zone Management

Cloudflare DNS management for djridhaboss.com
Screenshot - 6a3b85f24710912541e4ebd7706068a8 - Gyazo

CWP7pro Control WebPanel Settings:

EMAIL:

Simple rDNS Checker (PTR records)

DKIM & SPF Manager

Im trying to post the links but does not allow me :frowning:

Here is all:

You probably need to increase the size to read:
Sorry about that, I just didn’t think to post the original pictures. It does not allow me to.

If we’re looking at the (sub-)domain, that you are pointing your MX record to, … that (sub-)domain does not exist.

Add the following two records:

Type: A
Name: mail, or mail.djridhaboss.com
IPv4 address: 82.208.20.160
Proxy status: :grey: Unproxied / DNS-only.

Type: AAAA
Name: mail, or mail.djridhaboss.com
IPv6 address: 2a02:c206:2176:8254::1
Proxy status: :grey: Unproxied / DNS-only.

Once that is done, and assuming you’re also sending out emails through this Contabo VM, you would also like to change the Reverse DNS (PTR) record from pointing towards vmi1768254.contaboserver.net, to point to mail.djridhaboss.com instead.

A dynamic/generic looking name like vmi1768254.contaboserver.net will be frowned up on by spam filters and such.

New (e.g. recently registered) users are on most forums subject to stricter filtering and/or post moderation, which I believe is what happened in your case.

It isn’t uncommon for e.g. spam bots to join forums, and then spam away with a lot of links (or images).

Thank you for replay.
I done everything, but that not help either.


Got this message as always:
Your message couldn’t be delivered to [email protected] because the remote server is misconfigured. See technical details below for more information.
554 5.7.1 : Relay access denied

I even change on the server like this and still the same.

mydomain = djridhaboss.com
myhostname = mail.djridhaboss.com

I done everything you said, but with no effect.
Its the same.
I follow step-by-step.

No luck.

My Ip is Added to RATS Spam.
Its possible that to be the problem ?
I mean when i sent email to google from [email protected]
The email arrives at google.
But once i sent back from google to [email protected]
The error show up.
The thing is, email does not arrive at internal emails too,
when i sent email from [email protected] to [email protected] emails not arrive too.

This error means that the mail server hasn’t been configured to accept email messages for the given domain.

If you have configured this one, it seems like you haven’t reloaded the Postfix daemon, so that the new configuration would take effect.

If you can confirm that you do not have any typo’s in your domain name across your configurations and so, the lack of reload may eventually be the reason for the above Relay access denied as well.

That has nothing to do with the Relay access denied error, no.

1 Like

Hey,
Thanks for the answers.
Well i restarted the server, twice.
Its same.
I didn’t find a way to sent you private message here.
So if you have time you can check where the problem is.
Obviously i cant fix it.
Struggling with this a month. I done what you say and still not working.

Guys, is that the problem ?
I done everything DarkDevils said, but noting works.

Something hasn’t been configured properly along the way, in order for Postfix to accept messages for your domain then.

The Cloudflare Community doesn’t allow you to initiate private message before you’re at least on TL3 (Trust Level 3).

That would require some more sharing Postfix configuration.

What exact guide did you (try to) follow, in order to set it all up?

The error output you’re sharing there is only mentioning some file permissions, apparently in regards to vacation responders, and shouldn’t affect the general mail system.

The other "TCP_IN Blocked and "UDP_IN Blocked seems to be becacuse you have a firewall configured on you VM, but the traffic it is blocking isn’t related to mail traffic at all.

1 Like

Well postfix works, listen to all interfaces and all ports.

It send emails, but only to outside, does not sent emails to local, for example from [email protected] to [email protected]
Also from Gmail to any email not work yet.

What else i can try ?

I also wish you to thank you for trying to help me.
Not many does.
Thank you !

Here is the conf you ask for.

Stuff like the “virtual_mailbox_domains”, “virtual_mailbox_maps” and “virtual_alias_maps” are configured in a way where the virtual users are being fetched from a SQL database (with the details specified in the given files).

The file “virtual_mailbox_domains” refer to, may for example hold something like:

user = vmail
password = Ch4ng3M3
hosts = 127.0.0.1
dbname = vmail
query = SELECT 1 FROM virtual_domains WHERE name='%s'

In a the above example, Postfix would be looking in the SQL database “vmail”, that reside on the same machine (127.0.0.1) as your Postfix installation for the information about the domains that your mail server wants to handle mail for.

In the database “vmail”, you have a table named “virtual_domains”, which would typically at a minimum be holding an id (unique auto incremented number for each domain) and a domain, like this:

+----+--------------+
| id | name         |
+----+--------------+
|  1 | darkdevil.dk |
+----+--------------+

It will be in that defined SQL database that you need to add your domain name(s) to, in order for Postfix to realize that it needs to accept mails for the given domain name.

Similar to that, the information for SQL defined in the file that “virtual_mailbox_maps” points to, will be the one that holds your mailboxes (e.g.the ones you log in to with your mail client), such as e.g. [email protected].

In addition, “virtual_alias_maps” holds aliases (e.g. when want to point “[email protected]”, “[email protected]” or “[email protected]” to pass on the message to “[email protected]”).

Such SQL-based set ups are quite common on many tutorials that are available out there, however, they normally come with the steps to set up a web panel for them as well, for easier administration of your virtual domains, users and aliases.

So I’m wondering, … you didn’t set up something like PostifxAdmin, or any other kind of “control panel”?

2 Likes

Hello,
Thanks for the answer.
Well no, i didn’t set anything. I just installed CWP7pro 7 Control Webpanel.
The postfix are pre-installed with everything else.
Funny thing is, that is not the first time i set VPS with CWP7pro, and every time email was working fine, but before i never used Cloudflare as DNS.
If you have a time, please sent me message so i can re-play to you, will gave you login, passwords etc…
Or discord or email or anything else. You can check settings on the CWP7 and the VPS with root.
As you can see the problem i cannot fix myself.
Thank you again for the help.

And this will likely mean that you may end up on breaking CWP, if you’re touching the configuration (too much) manually.

There is no technical difference between using Cloudflare as DNS, or not, in regards to this.

The issue you are seeing is neither DNS, nor Cloudflare related at all, and would have been the exact same with the current set up, even without Cloudflare.

Although I do appreciate the trust, -

I would strongly suggest avoiding things like this, especially with strangers from the Internet, or other kind of people that you don’t know that well, or trust fully yet.

I would check within the CWP panel, for whether you have any actual domains (and users) configured first, which may be something like this:

How to Manage Email Accounts in CentOS Web Panel | Hostwinds

https://www.youtube.com/watch?v=aHLVTl_pfik

Create an Email Account in Control Web Panel (CWP) | InMotion Hosting

Some of them may be older links though, - but it seems like something with these parts hasn’t been set up properly through your control panel, and as a result of that, the domain hasn’t yet been been populated towards the Postfix installation.

The best would probably be to reach out to CWP though, as they are likely much more familiar with their own system.

I won’t give any SLA, or otherwise guarantee any sort of availability at all, but at the same time, won’t deny the possibility we can find a moment or two to take a look at some point.

If you’re okay with that, I have sent a PM with some details.