Email issues with InMotion Hosting


#1

Hello,
I recently changed the DNS of my site to Cloudflare - which is working great but email is not. I contacted my provider and they told me to do this:

Step 1) Add an A record for mail.longbeachrealestatephotographer.com and point it to 144.208.71.143

Step 2) Add an MX record for mail.longbeachrealestatephotographer.com and point it to the A record: mail.longbeachrealestatephotographer.com

Email is still not working though. My Cloudflare settings are (sorry, don’t see a way to add a screenshot):

A autoconfig points to 144.208.71.143 Automatic Delete
A autodiscover points to 144.208.71.143 Automatic Delete
A cpanel points to 144.208.71.143 Automatic Delete
A cpcalendars points to 144.208.71.143 Automatic Delete
A cpcontacts points to 144.208.71.143 Automatic Delete
A ftp points to 192.145.239.47 Automatic Delete
A longbeachrealestatephotographer.com points to 144.208.71.143 Automatic Delete
A mail points to 144.208.71.143 Automatic Delete
A webdisk points to 144.208.71.143 Automatic Delete
A webmail points to 144.208.71.143 Automatic Delete
A whm points to 144.208.71.143 Automatic Delete
CNAME www is an alias of longbeachrealestatephotographer.com Automatic Delete
MX mail mail handled by mail.longbeachrealestatephotographer.com0 Automatic

Can someone please tell me what I need to change? Thanks for your help!


#2

I would say your MX should have the name @ rather than mail.


#4

Also, when you reply, there should be an image option at the bottom right so you can add a screenshot.


#5

Also, if you’re not using cpcalendars, cpcontacts, ftp, webdisk etc. I’d remove those records too.


#6

Thanks so much for your help, everyone! I changed the MX to @ instead of mail and deleted those other records but am still seeing this error: An A, AAAA, CNAME, or MX record is pointed to your origin server exposing your origin IP address.


#7

When you proxy (orange cloud) that is when your IP is hidden *and if your email server is the same as your website, well that can’t be avoided.


#8

This warning should only be of concern if you have a private server with an IP that is only used by your website. If you use shared hosting, you can safely ignore this warning, as the hosting providers need to block access via IP by default. The same IP is shared by hundreds of websites, sometimes over a thousand, which makes access via IP impossible, except for temporary arrangements that nevessarily include another key, like your hosting account username.


#9

Email is no working! Thanks everyone for your help!!


#10

I can’t see anything from the DNS side doing a lookup,

Have you tried everything in:


#11

Sorry to say I’m still not able to send emails…and don’t get a the error message til a day later! Can someone please tell me what is wrong with my configuration? I’m on the verge of switching back to my regular DNS because this is costing me clients/jobs…please help - thank you!! :slight_smile:


#12

What is the error message you get?


#13

The recipient server did not accept our requests to connect. Learn more at [https://support.google.com/mail/answer/7720 longbeachrealestatephotographer.com104.27.165.200: timed out] [longbeachrealestatephotographer.com 104.27.164.200: timed out] [longbeachrealestatephotographer.com 2606:4700:30::681b:a4c8: timed out] [longbeachrealestatephotographer.com 2606:4700:30::681b:a5c8: timed out]


#14

You’re sending this from a different address or alias using the ‘Send mail as’ feature. The settings for your ‘Send mail as’ account are misconfigured or out of date. Check those settings and try resending.


#15

Think I see the issue now :slight_smile: Needs to be reset up in Gmail?


#16

Trying to find info on how to do this correctly…anyone have a link?


#17

What is the server listed in the send mail as? It should be mail.yourdomain.com


#18

In Gmail under sending as? The SMPT server is set to: longbeachrealestatephotographer.com

Are you saying I should change that to: mail.longbeachrealestatephotographer.com


#19

Yes, I think you should as that record is set to :grey: so resolves to your origin rather than :logo:


#20

Thanks so much for your help - that did the trick!! :slight_smile:


#21

No problem, glad it helped :slightly_smiling_face: