Email is not working on my .app tld

dns

#1

I installed an .app tld domain about 4 days ago, and though I initially had difficulties getting cloudflare to work with a wordpress installation there, the site finally worked.

However my test emails to my mail account at this domain were not arriving… not in my outlook client, nor in my webmail account. My web host suggested adding a MX record here (at CF) which pointed mail to my host’s domain. I did that about 36 hours ago, and my test emails are still not arriving at either inbox.

So I’m not sure what to do next. Any advice? Thanks.


#2

If your MX record points at a DNS entry that’s set to :orange:, email can’t get through. Cloudflare DNS set to :orange: only proxy HTTP(S) traffic.


#3

Thanks. In Cloudflare, this is the MX record:

(the lagertha … com address is what my host told me to use for MX. With a priority of 0)

Does this help?


#4

Is your mail client trying to connect to a mail server that’s in your domain? Or is it trying to connect to the same server that’s listed as the MX record?


#5

I’m testing two email clients. One is outlook. Unfortunately MS Outlook recently changed their email account setup, and all of the custom settings (e.g. incoming/outgong server, authentication, ports etc) have disappeared from the GUI. I haven’t yet been able to find a way around that. So I don’t know how it is attempting to connect.

But if I send a test email from my gmail account (to the .app email address) the mail is not delivered… either to outlook, or to webmail. It does not immediately bounce either. I get a message maybe 24 hours later that the message hasn’t been delivered. Does this help?


#6

Yeah, it helps…but makes it more confusing. If lagertha really is supposed to accept email for your domain, mail shouldn’t stall out for a day then get rejected.

Give MX Toolbox a try. Type in your Domain name, then let it give you the first result. Then click on Find Problems for more testing.
https://mxtoolbox.com

Then try the following one. Enter that lagertha server name and your email address, but leave the sender as the default:
https://www.wormly.com/test-smtp-server


#7

Thank you, I’ll do that and let you know.


#8
dmarc 	xxxx.app 	DNS Record not found
mx 	xxxx.app 	No DMARC Record found
mx 	xxxx.app 	DNS Record not found
blacklist 	xxxx.app 	Blacklisted by SEM FRESH
dns 	xxxx.app 	SOA Serial Number Format is Invalid
dns 	xxxx.app 	SOA Expire Value out of recommended range
spf 	xxxx.app 	Too many included lookups (13)

#9

SERVER -> CLIENT: 451 Temporarily unable to process your email. Please try again later.
SMTP ERROR: RCPT TO command failed: 451 Temporarily unable to process your email. Please try again later.
CLIENT -> SERVER: QUIT
SERVER -> CLIENT: 221 lagertha.asoshared.com closing connection
Connection: closed
2018-08-07 03:39:39 SMTP Error: The following recipients failed: [email protected]: Temporarily unable to process your email. Please try again later.
Message sending failed.


#10

That looks like quite an array of problems. You’re going to need to get some Helpdesk support. You should start with Cloudflare’s support first: support AT cloudflare DOT com


#11

ok thank you. I assume I can link to this thread


#12

It looks like you set the name to “mail” so then mail.xxxx.app will go to that mail server.
Try using “@” as the name instead. ("@" actually just means xxxx.app.)


#13

Wow… thank all of you! That was the problem… the @. It works now.