Email is not working - MX Record?


Since setting up Cloudflare, the email to the domain, hosted at BlueHost, has stopped working.

I deleted the MX record to see if it would make a difference.
I am not really sure what should be on this list, apart from the A and CNAME, or if I should delete everything else.

Anyway, I tried creating the MX record again but not sure what to put in the Priority field.

So now I have really screwed it up. Can someone else me please?

Shared with CloudApp

You must add the MX records again in order to restore the domain email functionality and do not remove that DKIM record too by mistake!

Hello Yoav,

Thank your for your reply.
What should I put in the Priority field please?

Should I leave all the other SRV and TXT records? or delete them?

Priority 10 is fine. But you don’t have an “A” record for ‘mail’. You need to Add an “A” record with a Name of just ‘mail’ (no quotes) and most likely the same IP address as your website. And make sure it’s set to :grey: DNS Only.

Thank you Sdayman! Your reply is much appreciated.

Here is what I have so far. I can send mail but not receive it:

Shared with CloudApp

Make sure your mail apps are configured to send and receive at mail.lesleylyon(.com)

p.s. You shoudn’t have that first MX record for “mail” that points to mail.lesleylyon(.com). I doubt anybody at your domain is using a [email protected] type email address.

Yes, confirmed. Both incoming and outgoing hosts are set to

I have deleted the first record, still not joy:

Shared with CloudApp

If anyone can help me on this please, it will be much appreciated.

After following two videos I manage to find in ‘support’, here are my current settings. My email client has both incoming and outgoing servers set to

I have had to return my DNS to Bluehost in the meantime as I can not be without my email for so long.

Shared with CloudApp

Thank you in advance.

Hey @user449, sorry missed the earlier replies but I see you were taking care off!

According to your last screenshot, delete the mail A record first then edit the existing MX record so it points to but keep priority 10 (as @sdayman told you).

If you delete the ‘mail’ “A” record, then the MX record will point to a non-existent hostname.

Interesting, but I never saw the “mail” set up like that before (with A record). As we speak, is pinging to so all he needs to do is updating that MX record.

Thank you to you both for the replies!

I did try deleting the Mail A record before, but it did not work.
I also tried two other ways suggested on videos the knowledge db.

I also wrote to ‘support’. Their reply is the following but I have no idea what this actually means, what changes I need to make, or if its even possible:

" As previously advised, Cloudflare does not proxy traffic on port 25 (SMTP) unless Cloudflare Spectrum is enabled and configured to proxy email traffic across Cloudflare.

If you do not have Spectrum enabled then no email traffic (SMTP) will actually pass through Cloudflare and we will simply resolve the DNS.

This also means that any DNS record used to send email traffic must be grey-clouded to bypass the Cloudflare network.
See Identifying subdomains compatible with Cloudflare’s proxy

The correct values for your DNS mail records depend on your email provider. Please see Managing DNS records in Cloudflare for instructions on configuring DNS mail records through the Cloudflare dashboard.

To request your email DNS records from Cloudflare DNS you can run a dig command from a bash console. Below is an example of requesting an MX record:

dig MX

If your email DNS records are resolving correctly but the issue persists, please review Email undeliverable when using Cloudflare then contact your email service provider to confirm your DNS records are correct."

Any clues are appreciated!

Your nameservers are not configured correctly:

You must point your domain to Cloudflare if you want to use all its benefits.

Yes, that is correct. In the end, they had to be reverted so email could be received.