Email don't work

Hello my email doesn’t work for sending, I think this is because of DNS records. Please help me…

Can you share your domain for a DNS records check?


Thank you for asking.

I am sorry to hear you are experiencing an issue with receiving and/or sending e-mails while using Coudflare for your domain name.

Kindly, see below suggestions and tips for troubleshooting.

Could you share a screenshot of your DNS tab and domain name here with us?, but please consider hiding/masking out the IP addresses while sharing, if so.

Usually, the MX record should point to a hostname such as mail , and the A (or CNAME ) type record for that hostname should be set to :grey: (DNS Only).

Furthermore, if you recently moved your domain to your Cloudflare account, I could try to troubleshoot at first sight without knowing anything other as it could be related to either:

  1. Wrongly setup e-mail related DNS records at the DNS tab of Cloudflare dashboard for your domain name
  2. Possibly missing some TXT/CNAME records (for SPF, DKIM, DMARC if so?)
  3. You are using a hostname like which is :orange: (proxied) rather than the unproxied :grey: (DNS-only) like (possible this one not existing or is :orange: instead of being :grey:) at the DNS tab of Cloudflare dashboard, in your e-mail client for sending/receiving server (MS Outlook, Mozilla Thunderbird, etc.)

May I suggest checking below article if your e-mail records (usually the A mail and the MX record) are configured properly while you are using Cloudflare for your domain name:

I would also recommend looking into the below article due to further prevention of your e-mails being marked as a SPAM at the recipient’s side:

Nevertheless, using online tools on the links below you could test and troubleshoot more what is going on with your e-mails:

Otherwise, you might have to troubleshoot if the port like 110/143/993/995 and 25/465/587 is open at your web hosting and contact web hosting provider to check this for you. If they are not open, then I am afraid you may not be able to receive any emails from using that web hosting/email provider.

1 Like

Hello…sorry, I didn’t see your answer. My Email still doesn’t work for sending. Here I attached DNS records screen.

Thanks for helping…

Note the section in the previous comment from @fritex about the hostname the MX points to needing to be :grey: (DNS Only).

Your MX points to your apex domain ( which is :orange: (Proxied).

This will not work. Cloudlfare does not proxy email protocols.

You need to either set your apex domain to :grey: (DNS Only) or create a different host name that points to the same IP and use that in your MX records.

I notice that you have a :grey: (DNS Only) entry for webmail. If it is at the same IP you could update your MX to use that hostname.

For outbound email, you need to make sure that your MUA (email app) is also using a :grey: (DNS Only) hostname. Depending on whether your account is being auto-configured, you might need to manually adjust settings in your MUA.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.