Email does not work

I also need help after pointing my website from siteground who hosts my email. I have tried many different things based on the community posts regarding this and done so many trial and errors, and no luck.

First, my email stopped working unless i was logged in through the siteground webmail app. Now after trying to get it to work it doesnt work at all and i need to receive important emails.

I just need a person to help me with my unique dns and help find where my dns errors lie in both SG and CF… if someone is willing to help i can provide private screenshots!

thank you in advance!!

  • kristin

Meaning you do not have an access to your e-mail?

If so, I am afraid you should contact SiteGround about this issue.

Regarding the Siteground and Cloudflare setup, depending if you use Siteground interface to manage your DNS, or you will have to completely deactivate your Cloudflare setup at Siteground and then go through the onboarding process using the article from below:

Kindly, never post private information and mask/hide them if you really have to due to privacy concerns.

hi there,

i just fixed the issue by deleting an extra A record that had the siteground hosting IP. My emails started flowing again. However, this isnt the first time ive found a solution only to notice my emails stop a few days later…

My site is pointed to Cloudfare name servers, I do not have Cloudfare installed on my Siteground account. I followed the tutorial when setting it up, but after the email issue I fear I have done things I don’t even realize I did.

Also, I had access to my email account through SG Webmail, I just wasn’t receiving emails on it, whereas before I was getting them, just not on third party apps like Mail iOS on my phone, or Spark on my macbook. (Note, both are solved as of now).

I do believe I have been having issues due to the dns not matching up properly since i’ve switched.

I would still love more personalized info on how to properly switch to CF from siteground, so i can double check i have everything set correctly.

thank you!